[Release notes] Vanha Rauma

Sorry, I’ve only discovered it now :slight_smile:

Well, to be honest I think that is a fair comment looking at the last updates… My Xperia 10 iii still is on Android since major bugs (e.g. loss of audio) haven’t been fixed yet. Apart from that, there still is one of the two main cameras usable only under Sailfish OS, yet. Since my Xperia 10 i is still running fine, I’m not in a hurry to move to Sailfish OS on my Xperia 10 iii yet. And I also have the feeling, that things are slowing down at the development side at Jolla… just look at their blog, no substantial updates for months. Let’s hope for the best, I don’t want to leave the ship yet!


[Release notes] Vanha Rauma mentions “Sensors of tele and uwide camera lenses are disabled for now” as an Xperia 10 III issue, without further explanation. This still seems to be the case for — is this issue being worked on, are there guesses of when it would be fixed?
I’m kinda disappointed in only having ⅓ of the cameras being operational.


The remaining back cameras can be enabled after Camera2 API has been implemented. It looks like the project can take still some time… Could someone shed some light on that?


Today I’ve received FOUR copies of the same SMS within half a minute or so. This is getting worse and worse (more copies, more often), and very disturbing.

I must check if someone has already filled a bug report for this. If not, I’ll do it.

There is SMS received multiple times (scheduled for tomorrow’s community meeting)
For repeat count, I have beaten you - I had a record of six few days ago :slight_smile:



I tried to update my Xperia 10 II Dual SIM phone to version, but the update got stopped at about 80-90% completed. After waiting about an hour I forced a reboot. The phone rebootet OK, and the phone shows that the version is updated, but I can’t see Microsoft 365 option in settings when trying to add an account.

Any ideas how to fix this, or am I forced to do a complete reflash?

Bizarrely, I’e recently had duplicte SMSs received multiple times on my iPhone. I’ve not seen it on my SFOS phone (yet).

I wonder if it’s the telco at fault?

1 Like

I think this can sometimes happen caused by some network error. I had this phenomena also in earlier times, before i got SFOS, on some simple (not Smart-) phones.

Finally the Bug “ofonod CPU guzzling” aka “the friendly pocked warmer” seems to be fixed. Didn´t happen for me since this update. Good work guys!


I just had this happen last night… But I must say that it has been a long time since last it happened so it has been improved at least!


Regarding bugs and bugfixes I have a general question:
To get bugs fixed before the next release is out, do I have a chance to perform a
pkcon refresh + version --dup or a zypper ref + zypper dup to get a fix?
Do I have to switch to developer updates for this, or not?

No, since Sailfish OS is not a rolling release, you won’t get any updates until Jolla releases an update.


You are right, the friendly pocket warmer rise again, but not that often, then hopefully fixed in next update?!

Or you patch, compile and deploy manually :slight_smile: This can lead to progress! But it’s a lot o’ work.

An sfos-upgrade --verify will install missing packages and show which ones were missing.


A question: I just recently had to use a comparison of all installed files on two different but identical from the vantage point of software configuration devices. I did listing of all installed pkgs and compared them. How does --verify do this? I can do RTFM if it takes up too much space here.

It does not compare anything, just sets SSU to the currently installed SFOS version and runs version --dup.

Do you want to …
a. compare installed RPM packages (with or without taking their versions into account?)?
b. compare files installed by RPM packages (shall be equivalent to “a. including versions”)
c. compare at file-system level

a. & b. are achievable via rpm -q subcommands (see section “query options” in man-page), for c. IMO find is best suited (but rsync lets you directly compare file-system contents on different devices, without the indirection via locally generated text files / lists).

No, not really, because bugfixes are not separately released in installable form: You can only opt-in to receive preliminary SailfishOS-releases (which may turn out to be the final one) by participating in the “early access (EA)” programme.
But EA releases do more likely contain bugs, hence you would rather achieve the contrary of a “less buggy SailfishOS installation”.

In theory you could build the corresponding RPM package and install it, as soon as a bug is fixed in the source code repository of this package: You do not want that, because source code changes are not well tested (or not at all), when they are applied to their repository.

1 Like

I was looking for packages that might have ‘failed’ to install. The update on two identical devices had differing results, although both appeared to ‘succceed’ (ssu re XX, ssu ur, zypper ref, zypper dup).

In the end I did

zypper -s 10 se -i | cut -f ‘2’ -d ‘:’ | sort -rn
to produce lists which I then diffed. That revealed the missing package.

The normal zypper update procedure did not install the missing package. Possibly a file operation error.

1 Like