[Release notes] Vanha Rauma

@miau. Thank you very much!
Best regards, Uwe.

It is, all the time. That is what I am repeatedly indicating / trying to get across, nothing more / else.

But you answer differently each time, so it is still impossible to know what you mean.

Even though you asked differently each time, it is still impossible for me to know what you mean, because all the things you are complaining about are not there.
(BTW, please refrain from making generic statements and accusations, just because you do not comprehend something.)

You clearly are not open to help/advice and just want to argue for the sake of it.

What’s with this bad-faith interpretation? (Quoting your words fits extremely well here!)
Apparently you just want to argue for the sake of it.

Side note: I always welcome support, if it is helpful, and I will always thoroughly review any advice given. I even like criticism, if it is posed constructively.
But you are just repeatedly questioning things I never have stated, thus it is logical, that I cannot answer them, but have to reply, “please re-read what I wrote” and “I have never stated anything such”.

Can you please point out which part(s) or words of the updated paragraph you perceive not to be “in a format that keeps true (=can be trivially updated) at least for a couple of releases” or which part(s) or words of the updated paragraph you perceive to indicate the following three statements you made:

Maybe you can also denote, why you repeatedly sound as if this impression you have constitutes a regression WRT “in a format that keeps true (=can be trivially updated) at least for a couple of releases” compared to the older version of this paragraph in the release notes.

1 Like

I also had a dimmed display during the upgrade on one of my XA2s. On the other one, the display was bright during the upgrade.

Mea culpa!

I had read this:

You will probably need to uninstall your existing Storeman and then install it using the new “Storeman Installer” app.


You will probably need to uninstall your existing Storeman and then install it using the new “Storeman Installer” app after the completed upgrade.

Since that has been basically how it has been turning out several times.

That would have introduced a difference in the instruction and a sync-point with assuring Storeman compatibility with the new wording.
But in fact it only keeps it… so there is no difference - and evidently it works.

1 Like

Updated my Xperia !0 II with normal GUI method, after reboot and install bar at ca 100%& it tuck for hour or two. I tried to power it down by normal methods, but it did not accept. Suddenly it rebooted with additional power cycle and then booted normally to the working GUI. It shows new version
It looks fine. No other issues found so far.

As explained lengthily in at various places (by mentaljam and me and again), this is only necessary when updating from Storeman < 0.2.9 to ≥ v0.2.9 and completely unrelated to SailfishOS upgrades. I already understood that this abbreviated statement may be confusing, SailfishOS release notes are the wrong place to denote this and it has become irrelevant many Storeman releases later: Hence I replaced it with “If you use Storeman, please update it to a recent version before upgrading Sailfish OS.”

For regular users (not on the EA or cBeta release channels) usually only, if one does not “update it to a recent version before upgrading Sailfish OS.”, because I try to have a working Storeman release ready, when the EA phase ends (although the fact that Jolla’s EA phases have become extremely short is detrimental to this goal for Storeman and other apps).

IMO the updated paragraph constitutes a big improvement exactly in these two aspects (and a couple of others), as pointed out.

P.S.: I am glad that you were able to ultimately pin down your misinterpretation, because …

  • … I believe our argument was confusing others, both users and sailors.
  • … it turned out that you stumbled over a sentence somebody else has written and which I tried to eliminate by substituting it with a more relevant and concise statement.

P.P.S.: Thank you for ultimately assuring, that my updated paragraph constitutes a vast improvement and is indeed temporally invariant. Now I hope even more, that @rainemak will update it soon, so it becomes part of these and future release notes.


On my Xperia 10 III the update to itself went smoothly and without any problems.
But after the update I was faced with the ‘IPv4 mobile data connection not possible’ bug again:

After hours of trial and error, the only solution was a full re-flash to Android 62.0.A.3.109 and then back to SFOS
However, i really don’t want to do this procedure with every update.
Does anyone have any idea what could be causing this problem?


@rainemak asked me to update this on his behalf because he’s not able to do it just now. I’ve updated the paragraph using your updated text @olf. Please let me know if it needs adjusting.

1 Like

Thank you very much.

Please let me know if it needs adjusting.

I sure will, which will be increasing “4.4.0” to the next SailfishOS release Storeman has been successfully tested on (for the release notes of that SailfishOS release).


I updated Jolla C and Xperia 10 III these days, but Alac is still not working - the error message “Alac not supported” still appears when trying to play a file with that codec.

Can someone check if the codec works on his/her device?

Edit: Codec works, but there seems to bee a bug in Media Player when trying to play an Alac file. I’ll try a little further and set up a bug report.

hi, my phone is since i entered the the securitycode for the upgrade into a kind of koma. screenbacklight is light, led is white but nothing happens… it is in this state for almost an hour…
any idea how to make it work again?
it is a xperia 10.

very gratefull for any help.



++++ edit: powerbutton and volume up solved the problem ++++ thx again

1 Like

The update process warns me about 300+ packages that I should revert to their original state before upgrading. Some of those are:

Kind of worriyng. Yesterday I updated from to
I do have chum and storeman installed. Is it safe to start the upgrade?

I don’t think my configuration and installed packages are exotic. If you need more info to get to the solution, I will gladly provide that.


This sort of warning appears sometimes when you are updating. I ignored these warnings all the time and I did not uninstall chum or storeman if nothing like that was recommended in the release notes.

This worked for my since 2017. But your mileage may vary.


I’ve deinstalled Storeman and Chum before updating, and reinstalled after update. Works, no issues. But on Chum, please take care what SFOS version is entered in Settings / SailfishOS:Chum field.

Most update times, I always ignored the packages warning. Update always successful except one time (there I had to reflash).
One time, I had a package warning regarding 2 packages, i deinstalled by cli before proceeding because I wanted to make everything good, but then a package warning came, regarding 300 packages! But then I ignored it, proceeded and it also worked (maybe a year ago…)

edit: Does this warning really mean, the user should manually remove 300 packages before proceeding, or is this more meant as a report to the user, that the updater will remove 300 packages automatically? But I can’t imagine that anyone really will remove 300 packages manually before proceeding with the update…


Take a look here for some advice WRT the “Uninstall the following …”-message in the SailfishOS-updater:


Just a warning about a 5G joke. :crazy_face:

Xperia 10 III flashed with (volte doesn’t work with my operator) and 4G+ data operational.
I made the mistake to activate 5G services in my provider’s user space … and 4G data doesn’t connect anymore (active but not connected). I tried to deactivate the option in the user space, but there’s something buggy which prevents the operation. I called twice … now I wait.

The most weird is that when I use the SIM in the XA2 Ultra, 4G data works normally.

Regarding the notes about 5G in last IRC meeting, I hope that 5G management is « on the table » for the next release.

1 Like

That’s weird… In Finland (with the early 5G mobile broadbands) the connection started with 4G negotiation, and kicked to 5G after that. 5G should not disable 4G. At least I don’t know any cases… I hope you get it sorted out!

1 Like

I picked up informations from my GSM provider and it seems, when you activate 5G services, that GSM Data negociation is directly done in 5G mode instead of what you observe in Finland. I told to provider’s guys that it’s a little bit weird to manage this way.

I’m still waiting for my 5G deactivation to recover data on the Xperia.


Don’t take that as a trurh. It was the case for this one operator providing 5G Internet for a friends home a good while back. Things may have changed.

Sure, but I hope 5G support will land on next release … no data since mid-august :frowning: