[Release notes] Struven ketju

Not so ridiculous. If I check processes on my desktop system, browser is frequently the top ram consumer with up to several gigabyte.

1 Like

Ouch! Maybe next time Jolla will need to port SFOS to a phone with even more RAM then.

Please, isn’t 3 or 4GB RAM enough for a simple browser? A browser works like a charm on a Raspi with 2 GB. Also firefox runs on a 15 year old 32 bit laptop with 1GB RAM without such bugs and crashes, only slooow but it runs without any issues.

6GB is plenty.

But 6GB is the reason i wanted an XA2 Plus rather than an XA2, and likewise the reason I got a 10iii instead of a 10ii.

1 Like

I hadn’t spotted this release, my 10iii is still on .16.

Does anyone know if this release does anything for the Element problem?

Unfortunately it doesn’t fix this issue.

1 Like

I am having a problem with the sd card. It is not recognised any longer after the update (it went smooth btw and the phone is X10II). Some pictures but not all I guess from the sd card are shown in the gallery but the file explorer tells me that the sd card is empty (which it is not).

And also most of my pictures taken with the phone’s camera are gone. I thought they were on the sd card but I can’t find them when plugging the phone to a pc. The uppdate process did not loose anything else besides the most of the pictures.

I have rebooted, shut down the phone and used the media index database refresh tool (not sure about the translation).

I tried searching the forum but did not find anything helpful. And yes, I did not make any back ups as I thought that my data of any value would be safe on the sd card.

Have you tried it directly in the PC with the proper rights to exclude the card itself?

The ‘stock browser crashing whilst scrolling’ issue was present for me at times on 4.4 (Xperia 10 III), and weirdly Firefox or Opera would never crash whilst scrolling on the same sites.

I have noticed that issue with the browser on 10iii after the latest update to Before that it was not that frequent.

On the other hand on XZ3 (unofficial port) running the latest update i.e. with 4GB RAM (not 6 as 10iii), the browser does not crash visiting the same pages.

On the X10 it’s less frequent but still present. Browsers behavior on tapping links is much better now.

I tried also shutting down the phone and taking the card out. Windows did not recognise the card and wanted to format it (thanks but no thanks). But now the stock file browser in Windows does not recognise the sd card being there any longer.
I am not sure how to exclude the card itself. Could you tell me in different words, what you mean, please? And thank you for your effort in helping me.

In Windows you need to be admin level user to properly check. If the filesystem of SD card is FAT based of course. If not you need to add a proper driver for it first.
In Linux it’s much easier to mount and check the content as root (or superuser). At least for me ;).

What puzzles me is that you do see some pictures in the gallery. Can you please check that they are on SD card and not in the phone memory?

Backup is always highly recommended. Every memory eventually fails. I highly recommend that you do it ASAP on another card.

Good luck!

XA2 → without issues. Bluetooth still doesnt work without some restarts from utilities. After a reboot theres also issue with calls - like both sides are muted. No signal, no voice one way or another (this issue is here from few releases).

I wonder if/when will support for Xperia 10 IV be added…?

On my 10 III I have that too occasionally. Image below contains RAM usage over three days from SystemDataScope. In that time line browser has closed during scrolling, but also at least with Chum gui. This doesn’t seem RAM related to me.

Thanks. I’ll grab my old laptop with Lubuntu and give it a try during the weekend.
And yes - the few pictures still left are in the phones memory. I use sd card for pictures and naturally thought that they would be read from the sd card. But no as they (like dozen or so) were saved in the phones memory as I had used them as mail attachment. So no further oddities there.
But I still don’t get. Why the sd card is working propwely before the update and after it not? The update process has nothing to do with the sd card, has it, or did I miss something? (My skills and knowledge are not very wide).

Good luck with Lubuntu. Try to create a dummy file and read it. Remember to use sudo for root like rights.
I don’t know if upgrade has anything to do with SD. Is card mounted and readable in Storage from Settings in SFOS?

At 5 PM. (Twenty characters needed)

Looking forward to it… Hopefully soon :smiley: