[Release notes] Struven ketju

Yeah that happened to me after the update to .16 as well. The only solution I found was to completely power off the phone and then turn it on again. A regular restart didn’t fix it.

After lots of try and error with different windows and linux machines I managed it to get it work through a USB-C Hub. Nevertheless rootfs/var/log/systemupdate.log has entries from last July 2022 - so no fresh information. Besides this there is a “systemupdate_4.4.0.72-from-” of a successfull update.
That means an Update to 4.5 was not done or started.

Update to went well. Nothing to complain here. :+1:

1 Like

I would recommend to do a full backup of the (decrypted) home partition. I had some troubles decrypting the home partition on my linux machine. After that, you have nothing to lose and can play around.
The first starting point would chroot rootfs
There you could ssu re and tell us, to which version the repos are set.
Read a bit more about the topic: Tried to update doesnt boot aynmore - #10 by nephros

And maybe also here: Tried to update doesnt boot aynmore - #44 by Drekkarian

Nevertheless, the content of /var/log/systemboot.log could also be helpful.

1 Like

Now I did update on one of my Xperia 10’s and @Stevo , you are right, there is no button.
I ran into the same problem because I forgot to deinstall Chum before updating.

So the following happened:

I looked for new updates manually (as always), device told me that update is available.
Started download, while downloading it reported that I shall delete the Chum-gui app, but I couldn’t do anything at this point.
So I let the download proceed until the end, then I did NOT pulldown+install BUT swipe up and app grid appeared.
At this time I was able to deinstall Chum-GUI by long tapping the icon and then tapping the x. Additionally I deinstalled Storeman.
After this, I closed the app grid and proceeded with the update with pull down → install.
It went fine without issues.

edit: GPS receives 28 satellites after a few seconds (much faster than before), but still no position fix after several minutes. (0/28) edit: Under conditions where Volla Phone and a Garmin GPS finds the position within <10 sec., X10 no fix. Under better conditions pos.fix is possible but altitude is wrong. Real altitude is 645 m ASL, displayed by Garmin & Volla (and a map). Sony X10 displays 670m. Before the update X10 displayed 680m.

reinstalled Chum from https://chumrpm.netlify.app/ - works.
Storeman reinstallation was fine using Storeman installer from Chum but now it updates database forever. edit: now it asked twice for permission and has now ready updated and everything’s fine.

Browser much better now!! Thank you Jolla!

edit: Update on my other Xperia 10 also successful. Thanks again Jolla!


Interesting, I also noticed that my altitude was 52m +/-6m, when in fact it is 20m ASL. (Android X10iii is reporting 48m)

Also it appears that Flightmode disables GPS regardless of the gps icon. (Android GPS still works as expected)

I did hope GPS had improved but seems not.
So I restart both phones next to each other, and inside the house. Data is turned off, flight mode on Android. (so there cannot be any assisted gps)

The Android took <90 secs to get lock. Most of that time was taken to find satellites. Once it had found ~10 sats, it had a position fix within seconds.
SFOS 4.5 took less time, ~20secs, to find 22 satellites. But it then took a total 320 secs to get a position fix.
This is the usual issue: it can see lots of sats but is very poor at getting lock.
Also interesting, Android is reporting using 14/17 sats, while SF reports using 6/33 sats

Try to reboot phone.

Yes thats true. Activating Flight Mode deactivates GPS despite Location icon in upper menu stays on. But it’s easy possible to switch off and again on while in Flight Mode and then it works again after resyncing with the satellites.

I managed to upgrade with “sfos-upgrade”. Thanks a lot for this script.
Unfortunately I had to uninstall A LOT of apps to have enough space. Probably there were some bigger left-overs from the former try. Also I had the same problems with seemingly lost android apps like sa (Aliendalvik not starting after update to - #14 by sa).
But in the end it worked well. :slight_smile:
It would be cool if Jolla would offer an easier way to change the root size than described here:
olf / SailfishX on Xperias · GitLab
Maybe Jolla could sell a special prepared USB-stick to just plug in, reboot to recovery and start a script to do all the work. I really would pay for it… @jolla
Happy sailing! :slight_smile:


Good to hear it worked well. I managed upgrading too meanwhile: [Release notes] Struven ketju - #51 by Stevo
Hopefully next upgrade runs smoothly. :smiley:
Happy sailing!

Browser problems.
The biggest Finnish newspaper’s (Helsingin Sanomat) site https://hs.fi does not work. It starts loading ok, after few seconds a message on the site “something is broken” then opens cookie selection pages which work ok. Newspaper can not be read.
The Finnish Meteorological Institute site https://fmi.fi , cookie selection page does not respond and can not be closed.
Both work fine with Android Firefox.

https://orf.at frequently crashes, especially when scrolling slowly.
Works always fine with Android Firefox.

edit: For me that’s the most annuying bug. (for the rest I’m happy with the browser at the moment)

1 Like

Thanks to martijntje and tom.i but bluetooth still not working!

On my 10 III flashed with neither site doesn’t seem to have problems. I can make cookie selections in dialogs and page content is visible. Maybe something in cache is wrong or similar?

I confirm that browser crashes when scrolling a lot on many web sites.

1 Like

If, by ‘crash’, you mean the browser going to the minimized tiled cover page with a rotating circle in the middle, and then reloading with the previous web site from scratch, then I get this regularly too. Perhaps a memory problem? Although, on an X10 III with 6GB, and the browser the only user app running, I can’t see why …

1 Like

Exactly this. I assume the often mentioned ‘out of memory’ bug, but I’m not an expert.

edit: Now I tried a lot but I’m no more able to provoke this bug on X10 /, so @Jolla I apologize!

edit: Sorry have to say this - bug still present at the moment.

Works fine for me with stock browser and

Here too on XZ2 Compact

Thing is, if it was a memory issue you’d assume it would happen with any app (i.e. Any app in use that runs out of memory just at the point it needs some more to do something), but for me it only happens with the browser - unless it is so inefficient of course that it actually needs up to 6GB on 64 bit arch just to load some websites. Which would seem a bit ridiculous, so it can’t be true …

1 Like