[release notes] Kvarken 4.1.0

OSM Scout is available in Store, up to date and compiled for aarch64.


I think the last API needed for it to be included was in SFOS in the last review. No idea what the dev will do though.

XA2: thanks for official Location configuration recommendation.

Having Pure Maps open, my Location tray icon keeps flashing, like it can’t get a lock, even though position is already correctly shown on map. Anything I can do to help it here?

First and foremost it requires QtLocation to be allowed, that’s the main reason why there are almost no map-based apps in the store : we don’t want to reinvent the wheel just to bypass this (unbelievable) restriction.


Doesn’t show up for me.
Either it still uses this, or updated translations didn’t make it somehow.

1 Like

I updated earlier today, and had a few problems:

  • I was able to receive a call after update, then the phone (Xperia 10) lost connection with mobile network, and I had to reboot it to get it to work again
  • shortly after finishing another call, the phone rebooted on it’s own, no idea why

I’m hoping that my problem with notifications not working has been fixed.

On XA2 (h3113 single sim), I do experience a problem with Android Gallery:

  • when I try to open it via Nova Launcher, it does show blank black screen without any pictures
  • both image and file picker in Discord does not show anything (sharing file into app works)
  • trying to download image in Discord restarts the app without actually downloading it
  • in Frost (OSS wrapper for mobile Facebook site from F-Droid) downloading an image or video restarts the app
  • in Messenger Lite, image upload says “No app for image select found” (normal file select works, downloading an image works)
  • in Firefox when I try to download an image, app goes into restarting loop
  • in Kiwi browser (Chromium based), when I try to download an image, the app crashes
  • etc.

I tried to overcome this with an alternative - Blackberry Gallery, but it does not work either (the app itself worked on Pie). On 4.0, everything worked as it is supposed to work.

I was able to overcome the downloading by sharing the image/video into X-Plore File Manager first and then it worked, but, it is an overkill over just pressing one button…

Does anyone know about a possible solution?

EDIT: Solved this by

rm -rf /home/.android/

and rebooting

However, another issue found. microG cannot be granted “draw over other apps” permission because of “feature not avaliable” in the Settings screen.


I checked and actually Jolla Maps is also available to JollaTablet. And I agree, Maps wasn’t perfect but it was native app and did its job as long as you didn’t want offline maps (it was online maps only) or voice directions.

Iirc, the Maps app wasn’t written in house by Jolla, but it was made by Swedish company for Jolla and for some reason they didn’t want to keep developing the app anymore after some time. I don’t know if they were aqcuired by some other company who told them to focus on other things or they started making their own navigation product for bigger mobile OS’ and didn’t want to put in the effort in SFOS anymore.

1 Like

Magic Earth (Android), Windy Maps (Android) or Pure Maps (Sailfish), etc.

Everything works better than the old application. I tried to install it recently for fun, but would be a lot of work in order to find, compile and install all of the dependencies. :smiley:

Biting on this OT, hook line and and sinker. :slight_smile:

It was done by Cybercom, the Gothenburg office if i remember correctly. Probably contract work, plain and simple (as they are/were a consultancy business).
My guess is that licensing terms/costs for accessing the backend (HERE maps) changed so that it didn’t make economical sense to keep developing it.


The work needed for these browser engine jumps is massive, I don’t think they have the manpower for one per release.

People app crashes when I access to one of my favourite contacts. Does anyone have similar issue? Furthermore, some pictures contact are missing

Finally, I solve my problem deleting and adding the contact again.

Thank you Jolla team! Especially for the Mozilla location service. I didn’t check it with my satnav yet, but my current location is now detected immediately.


Do you mean the “Maep” app?

@attah: You are right. There is no such change in Jolla Store. I was mistaken. There was a plan to rename it but that never happened.


@mattpenn: Done. Added a line under known issues.


@peterleinchen: Defender removed from the problems list.


Yes, indeed. But we are working to upgrade the browser engine again.


But please keep the version need >=0.4.1 in patterns-sailfish. Else someone could try to install older version…