Q: What is the real reason, that numerical keyboard pops up when alphakeyb. should?

This error occurs often since a few days.

Restarting the GUI by Sailfish Utilities helps for a while, but never forever. There must be a basic reason for this . I did install some patches for the keyboard , and then removed because they didn’t work . e.g. the patch to remove the space between the last suggested word and the dot (as in last sentence .

I really don’t want to reflash the phone and reinstall and configure all apps! Does anyone know what crashed here and how to repair it?

Also since a few days the sticking screen error occurs significantly more frequent. Can I manually deinstall some suspicious packages that maybe cause this malfunction and then reinstall them new ?

In my case it was just regular updates (but a community port, the volla). I haven’t seen this for months. I assume you are using or ist .15?

I have this problem on paid Sailfish X 4…15. It happens, for me, when the phone is put in landscape mode and the keyboard used to enter numbers using the numeric keyboard. Once this happens it is impossible to get the alphanumeric keyboard back without either restarting the home screen or rebooting. This is 100% reproducible and has already been reported on this forum as a bug by many people.

@poetaster I updated as soon as …15 was available, and it worked like a charm without any problems, smoother and faster as …12 , and browser was back at it’s old speed as it should be. I’ve got the feeling that I damaged something in the systen, playing with some patches, which are all deinstalled meanwhile. Unfortunately I’m not able to really check the state of the system for hidden bugs that may have occured by reason of my unlucky experiments.

@Steve_Everett Yes, it happens more frequently in landscape mode, but sometimes also in portrait mode.

I know that this was reported often and since a long time by other users, so i didn’t want to create the x.th bug report about this, but ask the community if there is the reason known meanwhile and/or a solution to repair this.

No solution that I know of. Jolla are.said to be working on one, but no indication as to which release it might get fixed in as far as I am aware. Others may know more.

Thank you @Steve_Everett , and to make this clear and not cause any amazement, @Star.Trek and Seven.of.nine is both me. It’s the account of my other phone, and by accident I logged in with the wrong account before.

Well, for me it started after updating on 4.2 (which I am still on). No keyboard patches and few apps installed here. I do not think it depends on your doing :slight_smile:
I am not aware of a permanent fix but as a temporary workaround I use the solution posted by @peterleinchen

systemctl --user restart maliit-server

After I used it once, whenever the bug represents itself I shoot up the terminal and press the the ‘up’ arrow to evoke recent commands (which is handy as the bug occurs quite often, every two days or so).

Here is the original post:

1 Like

Well, you both come through as ‘Andrea’ so I had assumed they were both you! I await your new ST Discovery persona shortly :relaxed:

1 Like

Yes, it’s both me, and I’m Andrea. And I have password manager on my computer and in my post #4 above, I clicked on the wrong entry, so I was logged in as Star Trek and saw it too late, after sending the post. Normally I’m always in the forum as ‘Seven.of.nine’.

What is ‘ST’?

ST = Star Trek! Discovery = The new series.


systemctl --user restart maliit-server

… fixes it without restarting everything.
I have no other insights to offer…

1 Like

Have added this command to Shellex just now, but am not sure what’s the correct setting for run: inside the app or fingerterm? Tried both, inside… has no visible feedback , fingerterm… starts but displays nothing at the command line . But no error message and keyboard working (felt) better than before . The reaction on touching the letters with the stylus is much better now!

Yes, that command does not give any output.

1 Like