Keyboard stuck in numeric mode

I’m back, here’s what I see when non-working numeric keypad appears at the wrong time. device orientation doesn’t seem to matter . .

That looks like what I see. I assume with “appearing at the wrong time” you mean that the numeric keyboard shows up when you expect a regular text keyboard? Or do you mean the keyboard is just popping up without input requested at all?

I do mean numeric keypad popping up when alpha keyboard expeted instead.

Also, I haven’t been switch to correct keyboard except with reboot.

My workaround has been to install OKboard. It doesn’t work for my phone (screen size is not supported), but enabling it and then disabling it resets the keyboard.

This way I only have to wait ~5 seconds for the keyboard to become available again.


The same issue happened to me yesterday on my Xperia 10 II.
The only way to fix it was by restarting lipstick. If it happens again, I will try OKboard.

Did you try ?
systemctl --user restart maliit-server
devel-su systemctl-user restart maliit-server

No, because I’m not that tech-savvy. I’ll try that next time first, thank you.

Although I was pretty sure that there was a way to restart the keyboard from the terminal, I didn’t know it off the top of my head, and my goto resource (googling it) was unavailable due to the problem :frowning:

OTOH, this discussion is now bookmarked for when the problem recurs, so we’ll see – eventually.

I can definitely confirm this bug, it hit me about five times after updating to Verla. I run into it in portrait mode, simply with the stock note app and sms.

I can confirm it happens on the XperiaX. I haven’t confirmed the circumstances. Reboot, while annoying, works

A restart of the Startscreen with Sailfish Utilities also does the job.


I’ve got the correct keyboard back with running the calculator (or some other app that uses the numeric keyboard).


I think this is solved. I haven’t been able to trigger this behaviour anymore in 4.3.

That did nit work for me. But 4.3 is just around the corner. :slight_smile:

Unfortunately it’s not solved in 4.3.

Confirmed. It just happened to me again on 4.3.

I can reproduce the error with the numpad now. It seems to happen consistently after PHillis app :wink: crashes. To narrow it down further for you guys I created a poll. Feel free to answer when the error appears for you:

  • appears after using PHillis app (regular close of the app)
  • appears after PHillis app crashed
  • appears after use of a different app (regular close of the app)
  • appears after different app crashed
  • nothing of the above

0 voters

I have seen this a couple of times, but never was that app involved. I don’t think it has to do with anything crashing either .

1 Like

After never having this bug (on any release, including 4.3) I now have it regularly since yesterday. Yesterday I installed and used the Value Logger app by @slava to track our local Covid data. It s brilliant and very useful app, but as soon as you use it to enter numeric data then they keyboard gets stuck as a numeric keyboard and this is displayed thereafter for any app when you click on any input field. I can get my text keyboard back by restarting the home screen in Sailfish utilities, but it is very frustrating.

If you have Jolla’s Utilities installed, there is an option to restart Home screen. That has helped me with this issue.

1 Like