Purging contacts from preferences doesn’t work

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): Xperia 10 II
REGRESSION: (compared to previous public release: Yes, No, ?): No

DESCRIPTION: When you try to delete all contacts from preferences under applications submenu, fails the deletion. The system outputs: the contacts couldn’t be deleted.

PRECONDITIONS: No accounts syncing. Only the Jolla account added.


  1. Go to preferences
  2. Go application
  3. Contacts, pulley menu: delete all contacts

EXPECTED RESULT: The application CONTACTS would be free of contacts.

ACTUAL RESULT: The contacts keep on the phone


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

just did a test on my spare Xperia 10 ii with nothing else than a Jolla account:

  • i created a contact
  • then settings > app > contacts
  • pulley menu > delete all contacts

and it worked, the contact i created has been deleted and i no longer have contacts.

How many contacts did you have?

Around 500 contacts i do have

I have 2 contacts on my Xperia X which won’t delete. I’ve tried your method of adding a contact but when I try any method (from the Apps->People->Delete all contacts or from the People app and selecting them all) they’re still there. I’ve removed the SIM card and disabled the Nextcloud account, rebooted several times but still they’re there.

As one of very little patience, this is really p*ssing me off!

I’m tempted to try hacking the sql database in an effort to remove them from there.

you can also try using devel-su -p contacts-tool to delete, its easier and safer than handling the db directly.

Thanks but it still doesn’t work :frowning:

The list command gives this result :-
ID: 5174 ‘Customer Care’ Name: ;;;; Collection: aggregate SyncTarget:
ID: 5202 ‘Voicemail’ Name: ;;;; Collection: aggregate SyncTarget:

devel-su -p contacts-tool delete 5202
devel-su -p contacts-tool delete 5174

But …
devel-su -p contacts-tool list
ID: 5174 ‘Customer Care’ Name: ;;;; Collection: aggregate SyncTarget:
ID: 5202 ‘Voicemail’ Name: ;;;; Collection: aggregate SyncTarget:

Any ideas?

Hmm, are these contacts stored on the SIM maybe?

Nope. The SIM isn’t installed in the phone. It’s laying here on my desk along with the SD Card as I’m playing around with the music on that.

I soon got tired of this so I’ve moved the 2 databases
devel-su mv /home/nemo/.local/share/system/Contacts/qtcontacts-sqlite/contacts.db /home/nemo/Downloads/
devel-su mv /home/nemo/.local/share/system/privileged/Contacts/qtcontacts-sqlite/contacts.* /home/nemo/Downloads/Contacts_Database/

and now the phone tells me that there are no contacts. Once I’ve finished playing with the SD card, I’ll stuff a backup on it and plug that in along with the SIM card and see what I get then.

Thanks to the respondents for their help.

Replying to myself again!

I deleted the all.vcf file from a backup I did prior to updating to 4.3.0 this week and restored that. Those 2 contacts are back again! So where might they be stored? They’re definitely not in the vcf file.