Pure Maps, voice navigation missing

Latest version of Pure Maps on XA2 dual sim: Voice navigation does not work, error message is:
“Voice navigation unavailable: Missing Text-to Speech (TTS) engine for selected language.”

Under Preferences -> General -> Language, I have chosen English (Danish seems unavailable).
When I go to Testing, I choose English and click “Test” - and it works!

So why does voice navigation work in the test but not otherwise?
Is there any possibility to install Danish as the language in the TTS engine?

Thanks,
Morten

1 Like

I have exactly the same problem in Slovenian language.

:zipper_mouth_face:… and me with osmand in french.

TTS is problematic in Linux. Selection of languages is rather small and there have been longer posts regarding it at TJC. So, no need to repeat over here.

To get voice instructions, you need voice engine (mimic or picotts) and your instructions should be in that language. So, when calculating the route, choose English as well.

From your description, I don’t know shat did you select as language for routing.

2 Likes

For me selecting English doesn’t change a thing. It works in a test and it doesn’t during navigation.

I tried with mimic and picotts with the same results.

OTOH I think it worked on the first try and at any further test just didn’t.

I have Picotts installed. I can’t install Mimic - it complains that …“Nothing provides libicuuc.so.63 needed by mimic 1.2.0.3-1.9.1.jolla.armv7hl” - btw, these version numbers are crazy! :wink:
I don’t understand what you mean by “selecting as language for routing”? I have chosen English as map language. Do I need to do something else?
Thanks, Morten

Re language: when you calculate route, you can set a language for routing instructions. These could be different from the map language. To be sure, remove calculated route, calculate a new one and check that language is set to English

Re ICU error: please search this forum, common error and will be fixed with updated packages. For that, 3.4.0.x OBS target is needed. As I have replied to this too many times already, I will probably start ignoring icu error messages…

2 Likes

Where do I set the language for routing instructions, please? There is no such option under
Preferences -> Navigation?

You set them up on every routing calculation. Right now, as soon as the destination is entered, route is calculated. However, when shown the route, you can click on the bar at the bottom, to get to route options. In the options, you can set language and then recalculate the route.

This organization was set to reduce number of actions done by users routinely. However, looks like it is more complicated to the ones who don’t know about it.

5 Likes

Ah, it works now. Thank you!

1 Like

After I installed picotts (slightly confused as it was installed in 3.0.3) and Pure Maps app upgrade voice navigation works. Thanks!