Publish app to openrepos [Solved]

Hi,

I just published my fork of Sailslack to openrepos:
https://openrepos.net/content/decon/sailslack2
When trying to install from storeman I can add the repository but I cannot install the application. Have I missed some step when uploading the app to openrepos?

Update: The problem was that I didn’t get the “install” option in dropdown menu in storeman, but when I testad again an hour later it worked.

1 Like

Yes, that is something that annoys me too from time to time. It happens when enabling a repository, or uninstalling an application and wanting to re-install.
I just work around this by closing storeman and open it again.

You should report your problem directly to the author of the application on Openrepos, this isn’t really the place for help with 3rd party applications.

1 Like

When i posted here I didn’t think there were some problem with the storeman app, but rather that I had done something wrong with my upload procedure to openrepos. Since openrepos doesn’t have a forum (AFAIK anyway) my options were to either ask maintainer of openrepos via https://openrepos.net/contact or ask here since openrepos is used a lot by Sailfish OS developers. (Well I could have tried TMO too, but not sure that would had been better).

Openrepos and storeman maintainers are not the same just fyi

I was thinking that too which also is why I didn’t consider contacting maintainer of storeman.

But your issue is with storeman app and you’re contacting openrepos guy, two different guys

Yes, but when I posted I thought I had done something wrong when uploading to openrepos. If I had known there were some problem with storeman then I would had contacted storeman maintainer instead of posting here.

If the .rpm is out there and can download from browser then it surely isn’t an openrepos problem? Again you mail the wrong guy about an issue with something he has no affiliation with

Well I guess I wasn’t smart enough to figure that out at that time. And I only considered mailing openrepos guy but I didn’t, I posted here instead.

No worries, openrepos guy used to have an app, but I guess he got disillusioned with … jolla? community? who knows, luckily the repos survived and storeman guy took over and we have a super awesome app to compliment super awesome repos, but yeah, it’s unrelated persons in case you have an issue with one or the other

2 Likes