Problems with installing the OS update 4.3.0

Well done up to here! :wink:

Just a small typo in url (note missing jolla/armv7hl),
Use e.g.

Something I really really struggled long time ago (and again today :frowning: )

thanks for trying to move missed post(s)
but this one belongs way ahead (as you see from time stamp)
here it does not make any sense

My wifes phone (Xperia 10 Dual SIM) hangs on downloading the update:
Remove Packages:

What can I do now with this?

Old system is SFOS, but updated through many versions since 3.2 or 3.3, username still Nemo and not defaultuser. Do I have to reflash the device?

How is the CLI command to remove theese packages?

edit: found the solution,

[nemo@Sailfish ~]$ devel-su
[root@Sailfish nemo]# pkcon remove libopusfile
[root@Sailfish nemo]# pkcon remove ofono-alien-binder-plugin

did it. After this, the update worked. Problem is solved.

Is there also a solution for regular users? I just want to make an update.
In my case I should uninstall the packages


Is there an easier way to remove them?

I don’t know what the second one is, but the first one should simply automatically uninstall itself when you install the OS update.

i ignored them an updated regardless.

came through unscathed.

Just logged in to say, that I didn’t actually have any problems updating the OS but the 1st manually made boot after the update was quite interesting.

I shut my phone (xperia 10ii) down a day after the update when attending to a concert and when I tried to restart the phone after the concert I got to the 1st screen asking for my passcode. After entering the valid password/pin-code the phone just stuck showing the keyboard for the pin and a spinning wheel. I waited for a short while and then manually rebooted the phone again and the same issue happened again. This time I waited for a longer time but nothing still happened. I then restarted it for the 3rd time, gave a wrong pin on purpose, got an error message for it and then gave the right pin and the phone started normally. Go figure :man_shrugging:

1 Like

Just to say this is something I reliably have after every update:
on first boot after the update the first LUKS unlock code is entered but the UI never (and I mean never, hours) appears.
Shutdown / restart for the second time and everything is fine.
X and XA2

1 Like

I also have the same issue on the Xperia X and 10 II, but I think it’s happened more often than only after OS updates. Sometimes it just doesn’t unlock anything. You can notice the difference in the spinning wheel, too: when it’s ‘fake’ unlocking, it spins smooth and fast and never goes away, and when it’s unlocking for real, it stutters a lot and quickly fades to black for the UI to appear.

After downloading the files for an UI update of my Xperia 10 II (XQ-AU52) (from version 4.2.0) to version 4.3.0, I get a message to remove or reset (“tilbakestill”) the package “feature-xt9” because it may create problems during the update.

I run my phone with a very basic setup with no use of Android nor do I have openrepos or anything related installed, and I never work “under the hood” of the phone – so I don’t know how to find and remove said file/package.

What should I do now?
Just go ahead? (I have seen others previously got same warning about said package when upgrading to 4.2.0 and then just disregarded it apparently without encountering problems later on.)

Hi there,
in my case, connman.service failed after Update to Suomenlinna

Before update, I removed the packages listed as obstacles, except for ‚git-minimal‘ and ‚gittin‘.
However, I later noticed that I forgot to disable the repos ‘openrepos-noonien’ and ‘chum’ .
The update itself went without interruptions, freezes or errors.

But after reboot connman.service failed and no connections are available.

Nov 12 16:03:20 Sailfish systemd[1]: connman.service: Main process exited, code=exited, status=1/FAILURE
Nov 12 16:03:20 Sailfish systemd[1]: connman.service: Failed with result 'exit-code'.
Nov 12 16:03:20 Sailfish systemd[1]: Failed to start Connection service.
Nov 12 16:03:21 Sailfish systemd[1]: connman.service: Service hold-off time over, scheduling restart.
Nov 12 16:03:21 Sailfish systemd[1]: connman.service: Start request repeated too quickly.
Nov 12 16:03:21 Sailfish systemd[1]: connman.service: Failed with result 'exit-code'.

To get a little bit more information in journal, i deactivate the row ‚StandardOutput=null‘ in connman.service and get this additional output:

Nov 12 16:11:00 Sailfish connmand[31780]: Unknown option --systemd

Unfortunately I couldn’t get any information about the connmand option ‘–systemd’ so i try to start connmand manual as daemon and without the ‚–systemd‘ option:

devel-su /usr/sbin/connmand -W nl80211 --nobacktrace --noplugin=wifi

This starts connmand, all connections comes up and everything works as expected, until next reboot.

Maybe someone can help me to find a solution so that connman.service can start connmand again automatically and I don’t have to factory-reset or reflash my device.

Additional Information:

Update done with GUI
Device: Xperia X (F5121)

Problem solved.
For anyone who comes across this problem:
In my case there was an old version of connman.service in ‘/etc/systemd/system/’.
Either I created this myself and don’t remember it, or this is a holdover from a previous Sailfish version.
However, the connman.service required for this version is located in the directory ‘/usr/lib/systemd/system/’ after deleting the outdated service ‘/etc/systemd/system/connman.service’ and a systemctl daemon-reload, connmand was able to start with systemctl restart connman.service.

My 4.1/4.2 problem with the loss of a wifi connection also killing the mobile data - requiring a restart - remains on 4.3:


I also get the message about feature-xt9. No Android or openrepos, but I have installed some extra packages with pkcon and manual rpms. I did install “Predictive text input” since last update, but uninstalling it does not change the message.

Does anyone still have the STK icon with EA 4.3?

No, I don’t, and I wouldn’t have missed it if you hadn’t asked. :slightly_smiling_face:

My phone: XA2 dual sim.
After upgrading, Android App Support was shown in “Settings” but did not respond / did not work. The solution: It was not installed any longer (but why then in settings?) I needed to install it through jolla store again.

Yes. The trusty old Saunalahti STK still there as always despite the operator becoming Elisa years and years and years ago. Currently on Xperia 10 II.

The Finnish Mobile ID service (which is tied to the SIM) is also functioning.

This icon disappeared on my Xperia 10 with the last update .

Yes, I still got it. Elisa (“Saunalahti”) here on X10II dual-SIM buy only one SIM inserted.

Perhaps running sfos-upgrade --verify helps? You can get it from OpenRepos.

1 Like

Yep; present on

ironically, right next to ‘screenshot’ icon