Problems with downgrading from Android 13 in Xperia 10 III

Emma keeps saying that device is locked despite I have turned on the OEM unlocking from developer tools. Checking the settings in the phone shows unlocking is allowed.

Also if I try to unlock it with fastboot on Linux, adb does not even recognize the device.

Does it still matter which USB port (2 or 3) must use?

1 Like

I would try to use an USB2 port. Does ‘fastboot devices’ show the phone?

No it does not show anything. And I plug the phone while pressing volume down so the light is green.

$ ./adb devices
List of devices attached

Why do you need adb?

I just tried if I am able to unlock the bootloader with it as Emma argues it is locked even though it is not.

But you need fastboot to unlock the bootloader not adb.

Now I tried running fastboot but it gives permission error about udev:

$ ./fastboot devices
no permissions (missing udev rules? user is in the plugdev group); see []	 fastboot

I tried to follow this tutorial and made udev rule, but it did not work.

Have you tried running fastboot as root?
Have you rebooted after changing the ufev rules? Just restarting udev isn’t enough.

Take a look at this guide and the comments:

Flashing a device (I did often meanwhile) on Ubuntu Linux for me never worked as user, always had to enter the flash command beginning with ‘sudo’ and enter root password after pressing ENTER.

Yes I ran it also as sudo, no difference. Now I followed that gist, and now it prints this:

$ sudo ./fastboot -l devices
????????????           fastboot
 usb:3-6.1 (this row appears only when I use -l)

Are those question marks instead of phone model concern?

You should try an usb2 port or try the command under 4. from this document.

I have used the USB2 port all the time.

Ok, and you did enter fastboot mode(led is constant blue)? Have you checked with lsusb if the phone is there?

Oh it was supposed to be the blue light and not green? Now I tried again and by running unlock command with sudo it did not give any error, but light turned to red and terminal printed <waiting for device>
Still in Emma it says its locked

So, you turned the phone completely off, hold the Volume UP button and inserted the usb cord?

Yes, those very steps.

When the phone is connected in fastboot mode(blue led), does ‘lsusb’ show it?

Yes, it is listed every time. Product ID is different though depending which way I connect.

You said before you were pressing volume DOWN.
You must press VOLUME UP to enter fastboot.

Yes. As I stated earlier, I noticed that I was pressing the wrong button, and after that I was able to enter the unlock oem command in fastboot without error, but it did not help.