Problem with WEP in the WLAN configuration (2. version)

HARDWARE: Sony Xperia XA


I want connect to WIDI-WLAN with WEP-Encryption.
(I can’t switch the system to WPA2!)
With my IntexAquafish it works well with an passwort in HEXMode.
The new Sailfish OS works with ASCII-Mode.
I tried additionally starting with $ and Ox, it don’t works!


I tried anouter WIFI with WPA2.
It works.
Therefore WLAN-System ist ok, only WEP don’t works correctly


  1. Stop WLAN
  2. Start WLAN
  3. I write the password and then I read the information (in German), in short:
    Sorry. No network possible.
    In German:
    Entschuldigung. Ledier konnte keine Verbindung zum ausgewählten Netzwerk hergestellt werden.


Connecting to the network



This is a new installed Sailfish on my smartphone.


Maybe it’s possible to work around the problem using this trick:

not too sure though.

Are you sure it’s because of the password? Usually the wizard should say ‘password incorrect’ or so, not ’ no connection possible’.

No, I am not sure.
In the meantime, I have the feeling that it is something else:

I was able to change the password and entered a password that I could also enter as an ASCII string. I get the same error message.
If I enter a completely wrong password, I get the information that the password is wrong.

So it is something else!
But I set up the access the same way as I did with my Intex Aquafish with Sailfish.

But I can not see what is different with the two devices.
This is just stupid!!!

What channel(s) is the WLAN working on?

Now it works on Channel 3

Try disabling encryption completely on the router. Only for a short time obviously, for troubleshooting.

Does it work then?

Without Encryption the connection works without problems.

I have tested a little bit more.
I have a HUAWEI Router for the mobile-net.
With a WEP-Encrpytion I get the same error-message.
There must be a bug into the Sailfish-OS netstack for the WEP-Encryption.

OK, good to narrow it down.

Unfortunately I have never, ever used WEP, but we can do more troubleshooting.

Basically, do this:

devel-su journalctl -b -f

You can do it in a terminal on the device or securely enable SSH access.

Get a visual divider by pressing Enter a few times, then reproduce the problematic behavior, then Ctrl-C out of the command.

You should now have a fairly compact block of log messages that should somehow reflect the problem you are having.

This README has some info on how to turn on debugging in connman:

1 Like

The system repeats following error message:

[wpa_supplicant][…]__wlan_hdd_cfg80211_sched_scan_start: 3475: Network input is not correct
Sonyfish wpa_supplicant[4658]: wlan0: Failed to initiate sched scan
Sonyfish kernel: PMI: smblib_get_apsd_result: APSD not done yet.

(Sonyfish is the hostname of my device)

Can you switch friom wep to unencrypted? Maybe that would do the trick.

I have tested the device also with the uncrypted router.
Then the device was connected to the net.

Is it possible that this fails because WEP needs RC4 and that has been disabled in openssl-1.x?

Can you try

openssl ciphers | grep RC4

on both SFOS phones, the working one and the nonworking one?

Seems it is even disabled in wpa_supplicant:

Can’t help but agree with the comment… WPA has been available for 20 years this year after all.

And if anyone really wanted to know, the package builds fine after changing that.


There is no command
in both devices!
There is only a directory

There is a package called openssl or openssl-tools which provides that command.

But @attah seems to have found the real reason, so you don’t need to bother with this any more. Thanks for trying though.

Switching to unencrypted permanently is not an option? WEP encryption doesn’t make any sense these days and you can achive a similar grade of ‘pseudo’ security by simply hiding the unencrypted network:)

I have found a (somewhat unsatisfactory) solution for myself:
I got myself a small repeater, which now sets up a second WIFI network with WPA2 in bridge mode and forwards the data to the first WIFI network.
This way, the rest of the network can continue to run as before.
Even though WEP has security flaws, it’s better than nothing. I don’t leave a bicycle unlocked just because my lock isn’t optimal.

My general view on this problem is:
Obviously there is a bug in the Sailfish system.
Either it will be fixed or the WEP option will no longer be offered.

1 Like

Why do you need WEP anyway?

1 Like