"Problem with changing the call forwarding settings"

REPRODUCIBILITY: It happens every time I try to add a number to the call forwarding option


When I try to add a number to the call forwarding option, gives me the “Problem with changing the call forwarding settings” error. That’s pretty much it.


  1. Go into settings → Apps → Phone → Call Forwarding
  2. Try to add a number for any of the options
  3. Click on Accept


The number is added and the calls are forwarded to it.


The error message “Problem with changing the call forwarding settings”


I only have apps from the chum repo and storeman, nothing related to calling though.

I’m nitpicking, but there is a missing step:
3: Click on Accept

How do you add a number? Directly by inserting it on the field or from a contact clicking on +? How many SIM card do you use? On which one are you working on?

On my Xperia 10 II, I don’t get an error when I enable call forwarding. I only tested on option If busy.

I tried both options, typing the number manually and the + sign, both fail. In this Xperia 10 II I have one SIM card and I am trying to route it to a SIM that’s in a different phone.

1 Like

I can reproduce it. It happens if I don’t set a country calling code. Can you test once again, but with your country calling code?

Sadly it happens even with the calling code, I just tried it again.


  • Disable If busy
  • Accept
  • Go back
  • Enter to menu Call forwarding
  • Insert number with the calling code
  • Accept

I tried it and the problem still persists.

Perhaps repeat all steps and catch some logs can help.

jolla-settings > /home/defaultuser/Documents/log.txt 2>&1
I did get some errors, here's the logs: https://pastebin.com/k6B9nCDj

Great. I’m looking to get more logs (as root). With this command I just get an simple error when I insert a false number:

journalctl -f -u ofono > /home/defaultuser/Documents/ofono-log.txt

With Ofono Log (from OpenRepos) I catched a lot of data. May attention that some sensitive data could leak.
I think you can only use Ofono Log and send the logs.

These are the logs from the Ofono Log app: 2022-04-21 23:38:40.182 slot1 IRadioIndication 53 currentSignalStrength_1_2202 - Pastebin.com

Journalctl just gives me this:

-- Logs begin at Thu 2022-04-21 23:06:09 EEST. --
Apr 21 23:07:10 Xperia10II ofonod[2754]: cf registration
Apr 21 23:07:14 Xperia10II ofonod[2754]: CF setting failed
Apr 21 23:36:37 Xperia10II ofonod[2754]: cf registration
Apr 21 23:36:41 Xperia10II ofonod[2754]: CF setting failed

I’m not expert at all, but I see nothing related to call-forwarding. Perhaps try again, but open first Ofono Log and then catch all data with journalctl again:

journalct -f u ofono > ofono-logs.txt

Check first if you see some lines related to call-forwarding just after CF setting failed.
Sorry, I should say it first.

I checked and I didn’t find anything related to call forwarding sadly.

There is also this guide from Jolla on how to collect ofono logs:

1 Like