PodQast: "nonexistent" media files - zero size episodes

I have observed this problem for a long time, at least half a year (I have used podQast for ~1 year now).

I will try to describe it as well as I can…

Sometimes something goes wrong with the download of an episode that has been enqueued in the playlist.
I don’t know what triggers this - maybe a network error during download.

The result is always the same:
The episode appears to be downloaded, but starting playback does nothing, it shows up as 00:00:00 length, with 0 chapters.
I can archive the episode, then enqueue it again from the library, but it’s still the same!
I can restart the app, restart the phone, it’s still the same.
Once or twice I managed to get out of this loop (and again, no idea how to reproduce it) but often I simply have to give up on that episode.

I can open that episode in the browser alright, and download the audio.

I have one such case sitting here right now. When I issue

devel-su journalctl -f | grep podqast | grep -E '\[W]|\[E]'

I get this when pressing play:

Feb 14 19:53:34 XperiaXA2-DualSIM ur-podqast[5533]: [W] unknown:0 - GStreamer; Unable to play - "https://avdl.ard.de/radio/radiotatort/Sesam schließe dich.l.mp3"

and this when pressing pause again:

Feb 14 19:53:34 XperiaXA2-DualSIM ur-podqast[5533]: [W] unknown:0 - Error: "Secure connection setup failed."