Pinetime and SailfishOS

How to use a Pinetime smart watch with a phone running SailfishOs.

1 Like

you need a companion app and Amazfit is the perfect app for that.
to download it, you may use openrepos Amazfish | — Community Repository System or the chum repository (maybe safer as Adam is closely working on that chum thing and will update it first in the future)
a useful blog partly in English (the rest in French) can help you too: Nico's blog — Posts tagged "PineTime"


I just got a Pinetime watch. Setting it up is not so easy. I’ll put as much information as possible to make things easier. I’ll try it with a few Jolla devices as Bluetooth behavior changes depending on the hardware. Sorry for the lack of links, my level is too low for posting more than two :slight_smile:

The watch is running InfiniTime 1.2.0. More recent versions are available, but I need the companion app to upgrade.

Nico has a nice set of posts providing much information (see Installing post and flashing post at the end) :

I would just insist two points :

  • In case of connection trouble, reboot the watch (9s).
  • Upgrade Infinitime.

Software available


Sailfish companion app for smart watches. Probably the best choice.

Even if available on Harbour, some libs have to be downloaded from chum.


GadgetBridge on Android

Android app companion for smart watches. Available on f-droid.


Xperia X (

  • Bluetooth discovers it (UI or bluetoothctl) but can’t pair (Nico’s trick to get it working). EDIT: If you reboot the watch (9s on button, you can pair it)!
  • Amazfish pair as InfiniTime. It also connect to the watch, send proper time and gets heartbeats rate. The connection dies after a while but the connection can be re-established. Then it can’t be re-established and you have to reboot the watch again. I’ll try upgrading the firmware of the watch (changelog indicate many improvements on Bluetooth). EDIT: Upragrading to Infinitime 1.6.0 really improved Bluetooth stability.
  • GadgetBridge can’t scan for bluetooth devices (I have not checked bluetooth status of Android for sailfish for ages).

Xperia XA2 (

  • Bluetooth could not discover the device. Rebooting the phone did not help. Rebooting the watch (hold button for 9s) did the job! Pairing was successful (GAP, GATT, BLE: IAS, CTS, DIS, HRS, BAS, ANS). Watch shows a blue Bluetooth symbol.
  • Amazfish can’t pair. EDIT: After upgrading Infinitime to 1.6.0, pairing works fine.
  • GadgetBridge can’t scan.

Jolla 1

1 Like

Thanks a lot :slight_smile:

I’ve read Nico’s post and his method (Paing bluetooth BEFORE pairing with Amazfish) does not seem to work on my Xperia X. I’ll try it with an XA2 (different Bluetooth version) as soon as I get home.

EDIT: See post above. TL;DR: rebooting the watch helps !

that’s weird - it worked with my XA2, and still works with my 10 II now.

1 Like

thanks for the link :slight_smile:
actually most of my blog is in English, I think I have maybe 2 or 3 posts in French :wink:

Thanks for your blog informations!

I’ll try to upgrade Infinitime (1.2.0 → 1.6.0) before worrying too much for the XA2 lack of connectivity of the X instability. I’ll keep the message up to date (and check for Jolla1 compatibility :slight_smile: )

yes, 1.6.0 is really a big step forward, no more nasty BLE bug!!! :slight_smile:


Xperia XA2

  • Keeps loosing connexion. Have to re-appair the watch to connect it back. Not been able to see logs yet.

I had this problem too, on my XA2 Ultra + PineTime with InfiniTime 1.6.0. Rebooting both devices worked, without having to disconnect and re-pair.

Just got my PineTime this week. Updating firmware to 1.7.1 worked fine from amazfish. Thanks :slight_smile:

Pairing is a bit of a hasle, but using the main SFOS menu works fine.
Downloading data doesn’t work however. I hit “Download Data” in the pulley menu, but nothing happens. I tried running the amazfish ui on the shell, but there is no relevant debug info in the shell while pressing the menu item to download data.
Om openrepos I saw some mention of changing the date. I did set the watch time one hour forward, also one hour backward, both to no avail.
Going in amazfish debug info, it still lists the time as 1970, which is confusing to me. Going into Device Settings and saving them, says the device doesn’t support saving settings.

Any help is appreciated :slight_smile:

Oh, this is on XA2 with SFOS 4.3. Amazfit is installed through chum.

downloading data will do nothing with the PineTime - it only works with Amazfit devices, e.g. the GTS.
I recommend you join the PineTime Telegram group, you’ll find a lot more help here.

Ah, thank you, that helps me to understand it well. For the PineTime only uploading new firmware is supported. GadgetBridge from f-droid was not able to scan on SFOS 4.3.

I don’t have telegram nor plan to use it. Maybe for the next reader :wink:

Make sure you are using the latest Amazfish from chum. When my pinetime was stuck on 1970, I was able to get an updated Amazfish and it worked.

As far as functionality, calls, notifications, messages and emails will generate alerts on the pinetime. Supposedly navigation and music works as well, but I haven’t tried. There are frequent syncing issues though associated with early/late sleep on SFOS.

1 Like

Gadgetbridge will NOT work. There is only bluetooth passthrough in Aliendalvik for sound.