Pinentry install - nothing provides 'libncursesw.so.5'

I use gpg2 in a terminal which requires pinentry which I originally got from here
https://openrepos.net/content/inte/gnupg-pinentry

Before updating 4.3 to 4.4 it suggested uninstalling pinentry - which it never did before - so I did, intending to reinstall it afterwards.

I now want to reinstall it, so I’ve re-enabled inte’s repo
https://sailfish.openrepos.net/inte/personal/main
but pkcon install gives
Fatal error: nothing provides ‘libncursesw.so.5’ needed by the to be installed pinentry-0.8.3-1.armv7hl

I see I have ncurses installed. Does this need a new version of pinentry?

1 Like

There is already a bug report. See [4.4] ncurses ABI5 compatability package not available