Phone app do not work

REPRODUCIBILITY (% or how often): always
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2
REGRESSION: (compared to previous public release: Yes, No, ?):


when start phone app tries to load and can be seen on the app grid for two second and then closes. After this the app always closes.
when someone ring, menu for answering a call does not appear
contacts open fine? when try to call from contacts nothing happened

How to delete call log without open phone app?
How to open phone app from terminal?







(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

open terminal and type
“/usr/bin/voicecall-ui” (without the quotes)

and post what it says

now phone app start correctly
what wrong?

But all phone numbers don’t associate with contacts,
i mean i see only phone numbers, not names

after reboot phone app again don’t start
import from file in phone app does not work “failed to load page (on russian)”
in contacts app all contacts stay in

strange - what about “/usr/bin/sailjail – /usr/bin/voicecall-ui”

any difference?

I guess the probe is there somewhere, but not sure what it means… Did you install any apps/patches or make any system changes since the last time it worked normally?

nope, nothing, last install more than 1 month ago/
Is the path correct?
Can i reinstal phone app from terminal?

To get it more like the normal case i think you should run this sailjail -p voicecall-ui.desktop /usr/bin/voicecall-ui

Not only is the command not working on my otherwise working install, there is an endash in it, not a hyphen/minus… fortunately @Amper didn’t copy it.

Anyway; if my command gives a similar error about /etc/sailjail/config/50-sailfish-allowlist.conf, that sounds like your issue (that file missing or being corrupt). I can’t see what provides it; as it is seemingly not part of the sailjail-permissions package (but it is present on my device).

Did you upgrade from console, or what could have broken it like this? Maybe a sfos-upgrade check, or reinstall of sailjail packages could solve it.

My XA2 tells me:
# rpm -qf /etc/sailjail/config/50-sailfish-allowlist.conf

1 Like

when i copy i see “?” in terminal, not “–”
and i don’t know how to print “–” in terminal on phone

Anyway i run you command - and phone app starts correct with all associate contacts

when i close phone app and open it from icon, phone app open without associate contacts

I said that endash “–” is wrong under any circumstance and you are better off not trying.
How odd that my command worked, since it is supposed to be equivalent to pressing the icon.

So now it has started opening from the icon? O.o
I think you have a broken upgrade… hope it can be saved. Have you done anything special to it?

after reboot phone app don’t start, sailjail -p voicecall-ui.desktop /usr/bin/voicecall-uirun phone app correctly with associate contacts, close app and start it again - work fine/

try to sfos-upgrade…

i don’t use console, or something special before phone app crashed

sfos-upgrade did not show anything interesting

change the “exec” line in voicecall ui desktop file to the same command that works for you…

Not that that helps you know what’s happening, bit might work…