Patchmanager patches in Koli 4.0.1

Are you using Windows when writing the patch? Line ends are different in linux & windows, and PM doesn’t check that.
[Edit:] I haven’t tested with the current PM version, but it gave me “file not found”-errors, if I made a patch in qtcreator and didn’t use notepad++ (or vi) to change the line endings to unix style.

That’s weird. On my 4.3 it works flawlessly.

Are you perhaps affected by https://github.com/sailfishos-patches/patchmanager/issues/71?

Miau, can you update this link, too? It doesn’t work.

Which link do you mean?

I figured it out myself, got these 3 patches working again in 4.3.

Launcher combined
No home caroussel[fork]
Enhanced lockscreen

I’ll look into how to put these into the webcatalog.

1 Like

Sorry, I mean link to your update of No home carousel. You published it in February.

I just uploaded it to the web catalog.

Sorry, the first release in web catalog wasn’t working, new version should be fine.

3 Likes

Web Catalog says it was compatible with 2.1.1.24, I cannot imagine that’s true, is it?

Thank you, set it to 4.2.

1 Like

Thanks for all forks. Perfect.
I wish you enough time and willingness for maintaining these forks as long as it could ;-).

Could someone also please make the ‘Animation settings’ patch compatible with 4.3? Being able to adjust the speed of many animations is really useful.

It’s working for me except it is conflicting with other patches. You can see conflicting patches from patch details. Some may work, but for me Launcher Combined don’t work with it. Also remember to allow incompatible patches from settings.

4.3.0.12 is now available as version in Web Catalog

1 Like

miau: Anyway, can you modify Enhanced lockscreen patch to unlock the phone only by swipe up gesture? Now, it can be unlocked also by side swipes.

I’ve allowed incompatible patches and I don’t even have any other patches enabled, it simply refuses to apply. I’ve tried both the version by ‘mia’ and the version by ‘kuba77’, neither applies. don’t know what I could possibly be doing wrong!

Edit: oh, I think I know what’s going on: the patch is looking for files in /usr/lib/, but I’m using the Xperia 10 II, so the files are in /usr/lib64/. So, I’ll change my request:

Could someone please make the ‘Animation settings’ patch compatible with 64-bit Sailfish devices?

You can make it work manually with patch command, and direct it to the right file

There’s a bug for that and a release coming soon™

1 Like

I’ve fixed launcher combined by Coderus and folders with small icons works perfectly. You can try rpm file if you want from here: https://github.com/carmenfdezb/patch_launcher_combined/releases/download/1.0.0-1/launcher-combined-1.0.0-1.noarch.rpm

I’ve tried to upload patch to web catalog but for some reason files are missing. Maybe @olf can help me?

2 Likes

What file are you trying to upload, and what errors do you get from Web Catalog?