Pairing Xperia 10 II with HC-05 did not work (Bluetooth)

Hi,

I’m trying to do app which read some sensor data from bluetooth signal coming from HC-05 bluetooth module which is controlled by arduino device.

But I got stuck right at the start. My Xperia 10 II did not pair with HC-05. It did find the device and when trying to connect, it will first ask password and then it shows ~2 second like connection was made, but then it disconnect and say nothing. Although it shows HC-05 in the list of paired devises. When trying to connect again it says something like “can not connect, make sure device is on…”. When I put HC-05 on AT command mode, it shows like there has never been connection between these two devices (which is probably true).

I tested and with android device there is no problem to pair it with HC-05, so module it self should be ok, right?

I’m not professional developer, more like beginner. And I have no idea where the problem is or how to start fix it. So if you can help me, please do it that simple I can understand. :wink:

I maybe should mention that pairing Xperia with my computer works as it should. So at the moment problem is only with HC-05.

You could try to pair it using bluetoothctl, see for example:

I tried, but it did not work.
It shows like pairing goes well (HC-05 does not agree with this), but fails when trying to connect:

[bluetooth]# connect XX:XX:XX:XX:XX:XX
Attempting to connect to XX:XX:XX:XX:XX:XX
[CHG] Device XX:XX:XX:XX:XX:XX Connected: yes
[CHG] Device XX:XX:XX:XX:XX:XX ServicesResolved: yes
Failed to connect: org.bluez.Error.NotAvailable
[CHG] Device XX:XX:XX:XX:XX:XX ServicesResolved: no
[CHG] Device XX:XX:XX:XX:XX:XX Connected: no

Also tried to set HC-05 as a master so that connection attempt would come another way around. Same thing happened; phone shows “connected: yes” and after a second “connected: no” again.