Packages need to be deleted in order to update to 4.3

REPRODUCIBILITY (100%):
BUILD ID = 4.2.0.21
HARDWARE: X10 II
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

Message tells me to delete package feature-xt9 and ofono-alien-binder-plugin.

PRECONDITIONS:

I updated all public releases of Sailfish OS 4.

STEPS TO REPRODUCE:

  1. go to settings
  2. load update via w-lan
  3. receive message

EXPECTED RESULT:

Download without warning.

ACTUAL RESULT:

There is the option to install the update when I swipe down. I did not do it yet because of the message.

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

What are these packages for? Should I delete them? If yes - how?

I don’t know much technically, but I’ve gotten that message before and just did “ok” and it was fine … It probably just conflicts with some other package update or something, and they will be replaced with new version.

2 Likes

If you have some openrepos repositories active please disable them manually for this update.
Else just update.

Please see for some insights here