(Not reproducible) Can't perform initial unlock if plugged in to charge

REPRODUCIBILITY: 100% but only here :sweat_smile:
OS VERSION: 4.4 and 4.3.
HARDWARE: XA2 and 5V charger

DESCRIPTION:

If the XA2 is booted whilst connected to this charger, it cannot be unlocked. The password/PIN form will reject a wrong PIN, but a correct PIN will produce a spinning loading icon forever.
This bug arose in 4.3.

Same problem charging from laptop (same cable – unlikely to be the problem). There are other issues with charging that I know others have had:

  1. XA2 not charging ~60% of the time.
  2. XA2 refusing to charge until reboot (~15%)
  3. XA2 refusing to charge even from the recovery(?) charging program. (~5%).

I saw similar reports in the past. IIRC it was mostly connected with chargers probably not providing smooth DC voltage. Can you recheck all that with different charger or maybe directly from PC USB port?

Can you please add a full step by step instruction? It helps to save a lot of time.
Thank you in advance :slight_smile:

Same problem when connected to PC.

What’s not obvious? Plug into charger and reboot.

As much as possible informations are needed to try determining the cause of the bugs.
The cause is not obvious and being able to cross informations helps much.

I tried on my XA2 (generic wall charger) and couldn’t reproduce. (DUAL 4.4.0.58)
However, It doesn’t start booting process when connected to the PC. (doesn’t react to pwr button press)

Of course it’s obvious :slight_smile:
Writing step by step is important for us to easily reproduce the bug and be sure we do exactly the same step you do. Let’s take an example. Have you already heard of the car that won’t start when you buy a vanilla ice cream? That looks obvious. Stop your car, buy a vanilla ice cream and voilà! In this case, the big missing information is how long the car stayed turned off. Because the guy parked every time on the same place, he could always reproduce his bug when buying vanilla ice cream.

Another missing information: what is the amperage of your charger?

1 Like

I guess that it wasn’t obvious to you that the steps were excluded because they’re obvious. :upside_down_face:
I have the same problem charging from laptop so it’s not the charger.

Most likely cause is then surely software corruption. How do I fix it?

I tried today and I was able to unlock without any issues.

1 Like