Not able to move WhatsApp backup from XperiaX to Xperia 10 II

I was moving my WhatsApp data from XperiaX to Xperia 10 II. I was first trying by myself to input the data to the location /home/defaultuser/android_storage/Whatsapp/ without success. That was the location of the WhatsApp files on XperiaX.
Then I found the instruction Whatsapp Setup | Sailfish OS Documentation. I followed it until the new phone step “Restoring of the Backup is offered, allow WhatsApp to restore the backup.” (Actually I was not using computer to move the data but the SDCard.)
It seems that I did not get a prompt where the backup is restored and imported to the system.
Have you had similar experiences? Do you think I need to reflash my device or are there some other tricks to import and to save my old data?
I have my WhatsApp installed from Aurora Store. The Version is SailfishOs version is on both phones.
EDIT 1: WhatsApp version on XperiaX is I’m currently installing the same version on JollaC to make a testbed. I will inform if I find a solution.

WhatsApp stuff is in


1 Like

Current place for “WhatsApp” directory is in: ~/android_storage/Android/media/com.whatsapp/

Also you have to change the right owners (for user/group). Mine works with: defaultuser/appsupport

Sometimes it’s a hassle to make the manual backup to work with a new install. Once i had to start the app and copy the directory just after i received the confirmation number but before typing it in. All i can say is keep trying. It eventually works.

1 Like

Thanks for the clarification. For some reason I do not get a text message from WhatsApp when installing the app. It has to be requested manually again letting the WhatsApp to guess I will redo the registration. It makes me patient because the time interval the next text message can be requested seems to increase. Now it is 39 hours:(
Copying the files with cp -R command from the original location seems to give groups as follows:
drwxr-xr-x 13 defaultu appsuppo 4096 Sep 15 22:51 Media
Permissions were same for Backup and Database folders but I deleted them temporarily to follow your advice to copy them just before typing the confirmation number.
I also downloaded the WhatsApp from their web page having the version currently on my phone. Now thinking positively that it might help also.

Hey, i have the same constellation with the exact devices. Maybe its my fault and i do not have enough skills, but the only device where i was really able to backup the whatsapp messages after moving to another device, was the iphone of my mother. Why is backing up the chat history in WA so complicated, you follow the official instructions but its not working. It somehow looks like purpose. Good luck to you if you are able to do it :slight_smile:


I tried to find help from various forums. I found a hint to use Airplane mode to prevent the registration process and to force WhatsApp to load a local backup. The first try was not successful but I got more phases and screens during the process. I think that giving the permissions right at right phase, setting the phone to Airplane mode at he right phase, answering right for the questions and may be copying the files at right phase could help.

I will try that again later but due to WhatsApp timer increasing with every try I cant proceed very fast. If somebody is able and willing to play with that solution proposal I would be appreciated. The link to the solution android - WhatsApp cannot detect local backup file - Stack Overflow

1 Like

Finally succeed!!!

First I installed the XperiaX equivalent Whatsapp version from to my Xperia 10 II. Then I followed the instructions of the web page android - WhatsApp cannot detect local backup file - Stack Overflow

Instructions seem to divert SailfishOS help page instructions Whatsapp Setup | Sailfish OS Documentation by not giving permissions in the beginning phase of the installation. I do not understand the Airplane mode function, but I used that phase like advised.

Either the same version on the phones or Airplane mode usage solved my issue. Hopefully you do not meet the same situation. For my luck I had an old JollaC and another sim card to iterate the solution.