No roaming for mobile internet connection

After using Sailfish OS on Xperia 10 III for 1.5 years, here are my experience with mobile data when roaming so far:

All tests done with ELISA FI sim card.
:white_check_mark: Estonia - works
:white_check_mark: Åland Islands (Ålcom network) - works
:white_check_mark: Croatia - works
:white_check_mark: Spain - works (tested both with ELISA FI and DNA FI sim card)
:x: Poland - doesn’t work¹
:x: Sweden - doesn’t work
:x: Germany - doesn’t work²

¹ Collected ofono.log during my visit in Poland for anyone interested. I had a lot of extra time here to try different troubleshooting steps: tried both SIM1 and SIM2 cards slots, tried all APN protocols (IP/IPv6/Dual), and attempted all tricks mentioned in Resetting oFono Settings | Sailfish OS Documentation.
² In Germany it was showing interesting behaviour: when mobile data was turned off it would connect to network with 4G, but as soon as you enabled mobile data the network was downgraded to 3G (but still without working mobile data)

I’m currently on vacation in France and SFR works while other providers don’t . So I need to manually lock it to this provider. I use Lidl Connect at home, a Vodafone reseller.

I frequently see the ‘reboot’ dialog and I loose dats data connection from time to time requirinf further reboots.

ps: I cannot delete anything I typed here in fennec, sorry for the typos… also words only appear once finished?

Went to the Netherlands and Belgium. No VoLTE and one reboot at entering each country but none (!) on the way out. Mobile data and telefone worked pretty well. Pretty much the same in Austria and Czech Republic.