No 'presence' in 'settings' app on pinephone


not sure why is this, but on my pinephone, i cannot see ‘presence’ submenu in the ‘settings’ app.

that’s the submenu where i can set my xmpp status on, busy, or away.

i have configured the xmpp account though, in accounts, it is set to active.
none of my contacts got synced. so i guess integrated xmpp client doesn’t work. and i cannot see the ‘presence’ setting at all.

os version is, that’s the latest, right?

is it the known issue?

Afaik it has been broken for a loong time with the Jolla telepathy implementation.

Telepathy-gabble-plus from Openrepos brings it back.


on pinephone it doesn’t. at least for me. :confused:

For me it helps deactivating and re-activating the XMPP account after having been offline and gone online again.

In fact, i run this via systemd timer every morning, and presence seems to work okayish:

for a in $(mc-tool list | awk '/jabber/ {print $1}')
if [ $(mc-tool show "$a" | grep -c "Enabled: enabled") -eq 1 ]
mc-tool disable "$a"
sleep 10
mc-tool enable "$a"
sleep 10
mc-tool reconnect "$a"
mc-tool request "$a" away
1 Like

nephros, your script fixed the issue!

thank you!

i wonder what is the power management state for pinephone? do you need to do it every day, because the phone sleeps and disconnects everything and then you need to wake up the jabber as well?

i also opened this thread about xmpp problems on my xperia device with the latest os version.

(still not sure that my pinephone os version is the latest. today i have the issue that jolla store tries to update some software and fails).

and there i do have ‘presence’ section in ‘settings’, and i do have jabber connection, and i receive messages, and i can reply, but all the contacts look offline. i tried your script on xperia device but it did not help to fix those, other issues.

again, thank you for the script. i rebooted pinephone, and i see my contacts’ status in the addressbook and contacts app. before the contacts app was not populated, and i was not able to use jabber at all, and i had no presence section in settings.

Hmmm. I just installed it, and the xmpp sharing plugins. Just in case I tested with shmoose (adjusted some server sharing stuff) and it seems the ‘in-house’ client really is dead. at least on the volla port.

the in-house is what we need sailfish for. that’s the essential feature of sailfish to have the addressbook integrated with messages, and plugins for different messaging protocols.

that’s the feature which came to the sailfish from maemo.

i don’t need sailfish to run the separate xmpp app.

I agree. There are a number of fundemental ‘stack’ issues which seem to be neglected, like telepathy, including D-Bus itself. It’s difficult to interact with Caldendar, with Contacts and the messenger is, well, an sms client.

The reason I turned to a ‘client’ is because I’ve been upgrading xmpp servers (prosody 0.12) and checking if clients can do MUC OMEMO file transfers, and such. It looks like this is not coming to Sailfish anytime soon?!!

i am afraid shmoose (though i am very thankful for its existence) won’t work for the amount of chats i have. it was slow when i was joined in some number of chats which was half a year ago, and now i have several times more chats.

(because i discovered more xmpp rooms but also because i started to use biboumi as an xmpp to irc gateway)

Ah, I hadn’t thought of the performance angle. Out of curiosity, what do you use on the desktop?

on a desktop i use two xmpp clients.

my favourite is pidgin, because it has multi-window interface.

i have many workspaces, so i sort chats on those workspaces. i have a script which sorts my pidgin windows to different workspaces.

but my pidgin reads/writes, of course, ~/.purple, and my ~/.purple is mounted from my own cloud nfs server (which is located at my home) so sometimes, if i have bad internet connection, i use dino.

i also use dino when i need to make a call, or i need to read omemo end to end encryption messages, which are default in blabber/conversations.

ah, interesting. I used pidgin with otr for years, but retired it when we switched to omemo. And dino is the backup client for graphical stuff, recently (since version 0.3). I miss a cli client, like bitlbee. But I don’t really use chat outside of work/sfos :slight_smile: