No possibility to lock the device manually instantly

HARDWARE: Jolla 1 - Xperia 10 II


When a custom timeout (e.g. 5min) for automatic device lock is set, there is not possibility to lock the device manually instantly. Not the hw button and not the lock icon behave like that.

The pulley overview/overlay screen (surely not the correct terminology) that also shows the ambiences
has a lock icon. I would expect that when actively touched, that it locks the screen (forcing to enter the lock code when activating the screen again). When leaving the phone alone then the custom timeout for automatic device lock should be the point of reference for the locking behaviour but from the user point of view an active touch of the lock icon, (or for the sake of simplicity of the implementation) or the pressing of the hw button, should lock the screen.


SFOS installed


  1. pass code enabled
  2. custom timeout for automatic device lock (e.g. 5min)
  3. try to lock manually


screen locked (forcing to enter the lock code when activating the screen again)


access the home screen/phone without entering the lock code




A desktop environment like GNOME has such possibility; delay for the lock of the screensaver; and a shortcut or lock key (keyboard must provide such dedicated key) for locking instantly


Try double-clicking the power button instead of single-clicking when you want to lock the screen. Isn’t that what you are looking for?


Ok, that was a hidden one, a so called shortcut. Thanks! Indeed it does what is described above. Not sure if this functionality is intentionally implemented. Anyway, the usability issues for the alternative way via UI and the lock icon is still present and should be addressed (so, your hint is only partly a solution albeit it is for me).

It would help also others so leon can you please mark direc85’s reply as solution?

EDIT: and maybe also close the report.

1 Like

Tap the clock on statusbar → lock icon is shown. Tap the lock icon to lock the device.

It can be done quite quickly, without really waiting for the lock icon to appear, almost like a double-tap.

nope, that does not lock the device. This is what this report is about initially.
It only make device go to sleep, and turn off the display, but once you wake it up again it won’t ask for the unlock code. At least this is how it is for me.

it’s only partial solution and the bug is still there. The lock icon in the top menu, doesn’t lock the device. Which would be expected based on the icon look.

If you have Settings / Device lock / Automatic lock set to “No delay” then it does lock the device. So it depends on that setting whether it locks the device or not.

the keyword here is “Automatic lock” and we’re talking about manual lock.
Why automatic lock setting would affect manual forced lock?

exactly the usability issue. It should not depend on something.

Don’t ask me, it wasn’t me who made it work this way…

Anyway, I guess that the lock icon can be easily patched to do the same as double click on the Home button.

yes it should be fixed in the system and not by patchmanager.

1 Like

thanks for the docs, however I’m unable to find there any information regarding how the lock icon in the settings drawer should behave.
Right now it’s obvious that because of how does it look like, one may assume that it will lock device without waiting for the timeout.