No more cellular network after update

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.3.0.12
HARDWARE (XA2, X10, X10 II, …): XA2
UI LANGUAGE: French
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:

After the last update, the cellular network (Bouygues Telecom, France) connection is looping. So no more network.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Install the last update
  2. Try to have a cellular connection
  3. Cry

EXPECTED RESULT:

Have a cellular network working

ACTUAL RESULT:

Looping connection, not working

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Hi, I have an xa2 plus with Bouygues as operator and I don’t have any problem on 4.3. (exept with mms)
Did you try to reboot your phone or switch to airplan mode?

Please try switching from dual to ip (settings / mobile network / data access point) and tell us, if this changes anything.
Cheers

Sorry to reply with a delay.
@kayoux I made several reboots and also tried to switch to airplane mode as usual. Nothing changed.
@tobset I already tried this (I already had this kind of problem with MMS, so I check it anytime a new update is done)

I had to flash my phone to get it useable. I’ll give a new try this afternoon.

Hi @kuronoyurei ,
My conf is :
Nom du point d’accès : a2bouygtel.com
Protocole : IPv6
Authentification : aucun

Thanks a lot, it was that IPv6 protocol change.
Before the update, it couldn’t work without mixed protocol. Changed for IPv6, and everything seems fine for now.

In addition, I had to change my settings for MMS, see this post