No capital letter after a dot

REPRODUCIBILITY (% or how often): about 50%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X 10 II
REGRESSION: (compared to previous public release: Yes, No, ?): yes, worked fine on Jolla 1 and C


The keyboard does not switch to Capital letters on the beginning of sentences sometimes.


Open an app to type text. Bug is triggered here in the forum i.e. with the native Sailfish browser.


  1. Open app to type, i.e. browser and this website.
  2. Write some sentences
  3. Look what happens after a dot is typed. No change to capital letters.


After the end of a sentence it was comfortable to not have to press the shift button. New sentences got start with a capital letter without pressing shift.


It stays in one mode without capital letters. I have to press shift at the beginning of a new sentence.

I’ve noticed it too, but I figured it was a Presage thing… If you’re on official, you should have xt9. Last time I had xt9, I think was on 3.4, and I think those type things all worked well…

The browser is affected, but e.g. not Notes, Messaging, some Android apps (Signal, WhatsApp). Maybe this is not a bug and depends on the type of text field.

QML does allow you to turn it off e.g. for URL or password fields. so it eould be interesting to look at the code of specific examples.

Not sure how it is with the browser.

Typing in the body of a new email and ending with a full stop only switches to capitals when I add a space. This is the same for Presage and normal English keyboard.

Using the Sailfish Forum application, typing in the body of a message box does NOT switch to capitals when I add a space at the end of a sentence. Also the results are the same with Presage and English keyboard.

So there is a difference, not sure where or what to be honest.

Personally I don’t expect an automatic shift without spacing first.

I mainly wish that you could tap on a word prediction, (which automatically adds a space), then tap on, e.g., a comma, and the comma would be placed directly after the previous word, without the space in between.

Maybe remembering wrong, but I seem to.remember xt9 doing these kinds of things better …

Someone made a patch a while back…

There’s this, maybe it improves things, or can be made so that it does:

1 Like

If it’s anything like the old QtWebkit it’s probably ignoring the Input Method Hint, where as QML Components do respect it when it’s set.

1 Like

I can’t get xt9 at the moment. I was tempted to buy an X10ii and a license when our port changed to aarch64, so I could get official stuff, but I haven’t been able to talk myself into it yet.

At that point, I might as well just use the X10ii.

I did buy an XA2 and get a license for that reason before, but it was different, because the XA2 is vastly different design, and I knew I’d never use it. But, X10ii is just a little taller, but quite similar besides that…