No calenders and contacts after Oauth Office365 account setup

HARDWARE: X10-2, XA2, X10


After a lot of problems creating the Oauth Office 365 account (always stopped at some point):
does not show calenders. Don’t even appear in settings. contacts not synced.



  1. update
  2. delete Exchange Office365 account
  3. create Oauth Office365 account


synced contacts and calenders


no contacts, no Office365 calenders, but all calenders from other accounts I do not even sync (calender sync disabled) show up twice or more



1 Like

Could this be related to deprecation of basic auth Deprecation of Basic authentication in Exchange Online | Microsoft Learn ?

My exchange account also stopped working yesterday evening

I’d be happy for any way without reflashing it. Is there a way to delete account stuff with telnet or whatever? The double and tripple (non Office365) calendars I do not even sync?

No, no problems on non-Sailfish devices. Something is messed up. Emails work, Calendars and Contacts don’t

1 Like

@apozaf are you using Microsoft 365 or Microsoft Exchange account ?

Office365. Exchange does not work anymore. I can still set up Exchange, but then the calendar and email app crashes.
Looks like contacts and calendar does not sync with Office365 account and Only Email works.

1 Like

I deleted all files in /home/defaultuser/.local/share/system/privileged/Calendar/mkcal/
some calendars are still under “manage calendars” in the app

Plz Jolla!
Non working contacts and calendars in Office 365 are a no-go.

This is strange: which phone do you use? I have a 10 II and a 10 III. Both have no problems with Office 365 calendar or contacts sync.
Sometimes synchronisation of email fails, but this is a known problem since quite a long time.

I tried it with XA2, X10, X10+, X10-2. Same

I have experienced the same. Contacts and calendars did not show up at first attempt.
After that I have fiddled a bit with disabling and enabling sync flag, disabling and enabling the account, rebooting the device and enabling the account again (strangely the first re-enablement attempt presumably failed). After that calendars and contacts started to sync normally.

Did not try to repeat the same again, so I can’t determine the root cause neither what is the real solution. Still hoping my experience might help.

On the site note (non related to the issue) - I experienced two hiccups registering the account:

  1. server address was empty (after acquiring authentication), so I have filled it up manually/blindly as and it worked,
  2. provisioning enablement switch was turned on (by default) this prevented successful completion of the setup complaining administrator required device to be pin locked (what my phone is anyway). Turning off that switch resolved it.
1 Like

Thanks. I tried that and now they somehow magically sync. But the email and calendar app crashes as soon I select a mail or appointment

1 Like

I uninstalled both apps and reinsralled them with the Jolla Store. So far seems to work. Maybe a permission issue?

EDIT: no, does not work anymore, only the first time. Now the account says “no connection”

1 Like

Also a problem for me on 10 III, after deleting the Exchange account and adding Office 365 I have no calendars and contacts. I will try the workarounds provided above and see if they work, but this is a service Jolla charges for. I hope they manage to fix it, it needs to be reliable.
Edit: After multiple disables and enables I managed to get calendar working, it started working after I stopped trying to sync contacts. Maybe because my organisation has so many, that was failing?