No bluetooth auto connect on Xperia 10 III

REPRODUCIBILITY: Every time
OS VERSION: 4.4.0.64
HARDWARE: Xperia 10 III
UI LANGUAGE: Swedish
REGRESSION:

DESCRIPTION:

Paired Bluetooth device do not auto connect if Bluetooth was initial disabled. After every system reboot or disabling Bluetooth I have to manually connect the device. Ones that is done, auto connect works fine until next reboot or disabling Bluetooth.

PRECONDITIONS:

Xperia 10 III with bluetooth disabled and one already paired Bluetooth device turned off.

STEPS TO REPRODUCE:

  1. Activate bluetooth on phone
  2. Turn bluetooth device on
  3. Wait for connection

EXPECTED RESULT:

Bluetooth device gets connected to phone

ACTUAL RESULT:

Bluetooth device do not connect to phone

MODIFICATIONS:

Only mod that is related to bluetooth is Patchmanager patch “Restart BT in SF Utilities” but disabling it does not help.

ADDITIONAL INFORMATION:

More users with same issue…

2 Likes

Which bluetooth device are you using?

Bragi The Headphone, Jaybird Bluebuds X (BBX1), yobola T2 Pro, JBL Charge2+ and Plantronics M75.

1 Like

Yesterday i had the same issue with my 10 Mk3 and Huwei AM-61.
I tried to disable and enable BT 5-10 times. No luck.
I didn’t try to use “Utilities”, I used “Forget this device” and pair it again.

If someone has a bluetooth device pairing automatically with his X10 III, is it possible to share a screenshot of the device’s settings? It’s under Settings->Bluetooth->Long press on working device, show device information.

I’m curious if a working device (one pairing automatically) has the profile AVRCP or not.

Mine has AVRCP and is auto connecting (expect the first connect must be done manually).

my headphones wh-1000xm4 don’t connect automatically

I don’t get it. What does mean first connection? On first power on of your bt device you have to manually connect?

After every system reboot I have to manually connect the device. Ones that is done, auto connect works fine until next reboot.

That’s an interesting information. May I ask you to update your bug report with this information, please?

1 Like

Come to think of it, i have probably been employing a workaround to this issue:
bluetoothctl trust <mac-address>

Must have found it on here somewhere, but can’t locate it at the moment.

With that, i only have a one or two connections per month that i have to help a bit.

There is a missing step. First one should be:

  1. Reboot your phone

No, you do not have to reboot, disabled Bluetooth is enough.

1 Like

Everytime i disable bluetooth, i have to manually connect the first time after enabling it. Or quoting myself:

1 Like

Confirmed on X10three, Aftershokz headphones and a cheap Chinese “BT Dialler” phone.

1 Like

This seems to be happening only with BT Headphone devices (as mentioned before, happens with my Freebuds 3 and my Creative speakers).

My Amazfit GTR is auto-connecting every time, even after reboots. I never had to manually connect it.
(Or maybe Piggz is “handling” the matter in the background with his Amazfish app).

This is a known issue. The Bluetooth device name is lost after a reboot. Workaround is to set again the device name at every reboot. This is also the reason for which I am not using my X10III as a daily driver.

I paired with my partners Subaru BRZ and have connected successfully. I then rebooted my phone to test, after reading here and it autoconnects to the car without issue.
update:
When restarting the car/repairing, the sony previously playing will restart but the counter will continue to elapse thus the time elapsed for a song is longer than actual song length.

I wish I had problems like no auto-connect. I can’t pair the damn thing with my car kit at all (as the only smartphone that I’ve ever tried with it).

Thanks for submitting the report @eson, and to everyone for the useful clarifications in the discussion.

I’ve created an internal report about this and so have also tagged it here as “tracked.”

1 Like