NextCloud picture transfers fail when using an LDAP account

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2
REGRESSION: (compared to previous public release: Yes, No, ?): ?


Nextcloud is able to handle LDAP accounts. Therefor a webdav file link is not:




But setting this in nextcloud’s account enhanced settings it is ignored by gallery and e.g. file app (except: Backup - that works when corrected - and calendar data is set right via the account creation)


Have a user account on Nextcloud via LDAP


  1. create nextcloud account
  2. (then you have remote.php/dav/files/user) correct (in account nextcloud enhanced settings) to remote.php/dav/files/uuid as shown in nextcloud
  3. open gallery
  4. select picture
  5. share to nextcloud


Message: Image saved (and of course image is transfered)


No message, but error on transfer page. Nextcloud log: remote.php/files/user/Photos is used which creates a 404.


This is an error on a fresh installed XA2, I have another one installed < 4.0 and updated to and I am sure the paths were set right (with uuid) and I did not edit these settings. These settings then were an example for the new device. With the older one it works fine for gallery and e.g. file app’s share. Therefor I set regression to ?


Known issues specific to Xperia 10 II

  • 5 GHz WLAN signal reception is weaker than should be



Problem still exists in It moved to the new sharing mimikry

1 Like

Problem still exists in

Silly: I crashed my Nextcloud and buildup a new setup. With this I created a new account and now: It works with sharing of pictures. But: instead of Photos which is defined in the settings it offers Documents as target directory.

Thanks for the bug report @cy8aer. I’ve created an internal report for it and tagged it as tracked. I also updated the title a little; does it still seem correct to you?

Could you elaborate a little on the steps that you go through to do this please? It’s not quite clear to me what’s happening (or whether it means the issue has been fixed).

Quite simple: My Nextcloud system is bound to ldap and a ldap group. If I create a user in ldap the user can log into Nextcloud. Inside of Nextcloud you can see the for- and surname defined in ldap, for login the login user in ldap is used. But you can see in the active user’s list that every ldap user gets an uuid. And this uuid is bound to the external communication, e.g. for webdav paths. IMHO the user account is only stored in ldap and for the communication it is swapped to this uuid. In addition the device accounts which can be created in Nextcloud are bound the user account (you create a hashed password string for your ldap user) but internally the paths are bound to the uuid.

On the SFOS side I only created a new account with the ldap id and the account device password. You now would expect the WebDAV paths be bound to the account name and may have the bias to create paths with it and at some points that could be seen on the nextcloud access log. But the path is the uuid! There is some mechanism which is used in parts to receive the uuid and stuff like e.g. CalDav/CardDav really use this uuid. But for me this failed with the sharing.

I recreated my nextcloud account some weeks ago (SFOS 4.3) and now it works with the uuid path and sharing too. But changing /Documents to /Photos when sharing an image or changing it in the settings does not work.

Wich means:

  • Open an image in the gallery
  • Press share button
  • Select Nextcloud
  • On the dialog as target dir Documents is shown
  • Change it to Photos (this directory exists on my Nextcloud)
  • Press share button

Expected: Photo is transfered to the Photos directory
Behavious as of February: Error in uploading photo.

hm and now: It works. Did you change something in 4.4?

BUT: on the account settings, enhanced settings the photo path is “Photos” but on the sharing dialog “Documents” is offered - you have to change it in the sharing dialog then. ← that is still not working, “Photos” should be offered in the dialog.

1 Like

I have the exact same setup as you and it works on my side
Do you possible have a folder that is shared from someone else?

Also please attach logs.

1 Like

Thanks for the additional info @cy8aer, that’s very helpful. Just so you know, I’ve copied this over to our internal ticket too.