New sim card caused spontaneous installation of nonremovable app

I have a problem. A few months ago I moved to Simyo, a ‘daughter’ of mobile probider KPN. With the new sim card inserted an app emerged spontaneous. I cannot remove it. After opening the app I see two texts: Mobile Connect and MijnKPN (myKPN). When tapping on the texts I only get a website: and
These do not lead to the browser, only to ‘ok’.
I asked Simyo and they say that this is a simcardmanager and that it is standard on Android devices. They also say that Simyo does not use this app, but that it has no effect on the capability of the device. My device is a Sony 10 III with Sailfish. I explained to them that this is Linux, but they don’t understand. They advise me to contact Android (?).
I don’t want apps that are not installed by me and certainly not such a mysterious one. What can it be and what to do?
You can see the Simyo app (with Sailfish icon!) left under:

1 Like

I have a problem.

No, you don’t. See STK / USAT, e.g., at SIM Application Toolkit - Wikipedia.

I cannot remove it.

Sure you can: Remove the SIM card and it is gone.

Insert a SIM card of a different provider and there will be a different “app” started by the same launcher icon.

This has been discussed many times, for 8 years and counting, e.g.:

Plus, it has the properties (“features”), that the STK / USAT icon will always be on the top level of the launcher and there is no GUI-way to remove it: Both seems to be part of the specification, I have seen Android- and BlackBerryOS-devices behave this way, too (put this icon in a launcher-folder and it will reappear on the top level after the next boot-up).

P.S.: Actually you might be glad, that KPN provides such a minimalistic USAT-app and does not force you to use it by making it the only way to use some of the provider’s services.


Thank you for your quick reply. I have this problem because I have doubts about the necessity of this development. I don’t like it at all. It appeared a few months ago when I switched again after having tried Ben (TMobile) and Vodaphone. A few years ago I had Simyo without this ‘simcardmanager’. TMobile and Vodaphone did not show such an app on my device.
A year ago KPN said in a forum that it was the first one who was going to implement this tool. It is in the screenshot below, in Dutch.
I wonder why it is used in Android and not in iOS.
It surprised me noticing that my Sony with Sailfish happen to have an Android OS too and that the mobile function seems to run within the Android System.
A Nokia N900 will not help I am afraid, for that has 2G only.

You still do not have a problem, this is a service that your provider choose to give you, it can have multiple functions.

IOS chooses to “hide” the toolkit in a menu instead of on the app grid.
I found an image on the interwebbs,

1 Like

The weird thing is not that you now have that app, but that you did not have it earlier. The SIM toolkit is standard for all providers I know of.

Thanks, Apple hides it, hat’s clear. Yet this tool gives mobile providers the possibility to interfere and I doubt if this is a preferable development.
I think tech should be more transparent and not more secretive.

1 Like

Yes, strange. I gave my husband my XA2 with Sailfish without that app. He has an der sim from Simyo and it shows no such a non removable app.

In my Dual SIM when I only had German Congstar my phone didn’t show SIM Toolkit app, since I added a Vodafone app I have this app. When you open this app it shows Vodafone’s services and states that there are no services available for Congstar. So there’s a chance that the app is only visible if there are services available from your SIM card.

1 Like

Recently, a good friend’s phone was hacked. Trip, different country, different SIM card. Then I found out that a SIM card is a SOC (System On a Chip). Java programmes are happily running. In a so-called Sandbox like SailfishOS does? I need to do more research on this… Example of what a chip card can do: I am in Germany and call someone in the Netherlands via my phone book. I stored that number (carelessly) without a country code. And yes: convenience serves man, a programme on my chip (i.e. computer) changes the outgoing number before the connection is made to a number including the country code. So it is also possible to reroute my phone call to I don’t know which exchange eavesdrops on it completely unnoticed while the connection is transferred in real time. Or spontaneously calling a very expensive paid telephone service, without me noticing. Except that I am presented with a substantial phone bill afterwards.
And as for the result of the hack: the Android system software had been totally taken over by malicious software. Only re-flashing and a new SIM card seemed to be the solution. Decided on a new SIM card and a new phone.

Translated with (free version)

1 Like

BTW, I rediscovered Jolla’s old help article how to disable the STK (SIM application ToolKit), which also denotes some drawbacks of doing so.

Nice, now that jolla are themselves customers of cloudflare maybe they can push them to not treat their own users as bots (first time opening that link worked, after crash endless ‘smart’ captcha)


Can confirm. Maybe they became customers to be able to talk to customer support of cloudflare :wink: