New Monitoring and system controlling app: Monit

Hello all,

I have packaged and pushed to Chum Monit, a system monitoring and configuration tool.

You can use it to monitor certain properties of your system, remote systems, programs, processes and much more.

See Monit Presentation for an introduction, and M/Monit | Wiki for details on what it can do.

Contrary to most tools in the class monitoring its purpose is not so much drawing pretty graphs of historical data.
It is more about reporting and reacting to changes in the system state, send alerts, execute scripts on failure and so on.

Configuration on Sailfish OS

The package comes with a configuration structure at /etc/monit.d/. Any file ending in *.conf will be picked up by the monitoring daemon. Please use that directory to place your custom configurations.

There is also an extra package called monit-contrib, which ships a couple of example config snippets you can try out. This package will create dirs at /etc/monit.d/available and /etc/monit.d/scripts.
To enable any of the shipped configuration snippets, make a symlink from /etc/monit.d/available/foo.conf to /etc/monit.d/foo.conf.


The monit-contrib is intended to be expanded by YOU, the hackers, devs and power users with your configurations and additions.

So if you decide to play around with monit, and write some useful configurations, please submit them at GitHub - nephros/monit: monit and I will include them in the next iteration of the -contrib package.

Of course you can also publish RPM files to place files in there (or use Patchmanager, although that’s kind of abusing it).


Start/Stop the daemon using systemctl [start|stop] monit.service. This runs as root.

(You can also let monit run as a regular user, but you’ll have to set that up yourself using the official docs, and creating a config at ~/.monitrc.)

Note there is a startup delay configured, you will have to wait for some minutes until the interface comes up.

Web interface
The daemon has a web interface at http://localhost:2812 so you can monitor your monitoring and interact with the different monitoring targets.


When you call monit on the command line it acts as an interface to a running deamon. Look at monit --help and devel-su monit status for some output.
For your convenience, a bash-completion file is available at /etc/bash_completion.d/monit

Sailfish OS GUI App

I have also started to work on a GUI app. It’s in alpha stage at the moment, but you can find it here, and it will be released to chum “when it’s ready”.



It is more about reporting and reacting to changes in the system state, send alerts, execute scripts on failure and so on.

Monit predates systemd and in a way cat serve some similar purposes.
Myself I use it instead of systemd in parallel to a traditional init system on my Linux machines (run from inittab). Highly recommended if you’re partial to Team No Systemd.

On a system running systemd like SFOS its service managing capabilities may seem superfluous, OTOH it can still serve as a useful addition with it’s easy configuration language and flexible modes of operation.


Big work, Wow, and a very nice swiping website!

Just to be clear, all of Monit is not my work! :slight_smile:

Like many things, I just package the work of others here! :slight_smile:


I like nmon but i haven’t compared those two

Unable to connect. Browser can’t establish a connection to the server at … (yellow frame).

Xperia 10 Dual SIM, SFOS

I installed from Chum, tried, entered systemctl start monit.service , tried again, rebooted, tried again,

Still ‘yellow frame’. What can I do?

Wait 300 seconds after starting :wink:

I put in this delay for the reboot case, but it’s probably a bit too long…

Find the line set daemon in /etc/monitrc and adapt as you like.
But be aware this influences the cycle time for checks!

I’ll put a more reasonable default in the next package.

1 Like

It’s no problem to wait 5 minutes. This works now after waiting. But it asks me for setting a username and password. I tried to do this and want to store and login, but it leads me in circles and doesn’t accept, permanently asking for login again. What can I do?

edit: have updated to SFOS right now.

edit: I also tried now to enter username ‘devel-su’ and my devel-su password, but it still leads me in circles and shows the PW and UN from the first attempt.

The password is left at the default configuration, ‘admin:monit’ should let you in.

See the line set httpd port 2812 in /etc/monitrc if you want to change it.


It works, thank you!

Now I again have something to study! :wink:


Try this as regular user in terminal:

devel-su whoami

It asks for password and then says ‘root’.