Netshield adblocker ProtonVPN not working using Android apps over 4G


I have noticed that the optional Netshield adblocker for ProtonVPN does not work for Android apps when 4G is used. Over WLAN, it does work. By the way, I don’t use a VPN on my router. (Because I can’t use WireGuard and OpenVPN halves my internet speed. In fact, it only works on 1 core, unlike WireGuard).

Tested with Firefox and all add-ons deactivated, on the fantastic website:
Ad Blocker Test
by Eduard Ursu.

Via WLAN, according to the test, about 75% hosts are blocked. Via 4G about 10%.

The problem does not occur when I run the test with the system browser of SfOS.

You may find that I should have reported this to the topic
Mobile VPN usage, ipv6 not routed and DNS leaks - #10 by jlaakkonen
but I can’t identify any dnsleaks. And websites that allow you to check if IPv6 is working, show that it is off. I have tried - as far as I understand anything about DNS - to block IPv6 in all sorts of ways. That did not solve the problem. By the way, ProtonVPN doesn’t allow IPv6 at all because of its insecurity. I use the default VPN with OpenVPN as the setting. The setting “Turn off IPv6” gives no difference.

Can anyone assist me to solve this problem? I would greatly appreciate it!
Kind regards.

These buzzword brand names doesn’t say much… What should it do? Is it just a dns thing?

A VPN provider that also allows you to block ads, malware and tracking from your internet connection. This works by filtering hosts.

On Android, Blokada and personalDNSfilter are well-known programs. However, these work by impersonating a VPN connection. The result is that you can no longer use a VPN. On Android 4G.

I hope I gave you enough information. BTW: thanks for your interest.

Presumably that just means using their DNS.
And it would be good if that was what was stated, as opposed to brand names and buzzwords.
Yes, i realize you can’t necessarily know, but the truth is you’ll be hard pressed to find anyone that cares enough to find out for you. But if it is a general problem in what could be seen as basic functionality, you’ll have a much better chance of getting this picked up.

How is this relevant to Sailfish OS?

You asked me about buzzword etc. I was hoping to clarify what the problem is with this.

Don’t get me wrong: I don’t use buzzwords to advertise. Surely it is remarkable that there is a difference whether I use 4G or Wifi. A difference that occurs exclusively with Android applications using 4G.

I asked you to refrain from buzzwords (not add more), so it can be clear what the actual issue is.

@attah I think you’re over critical here. @jolla4ever uses a service provider that is well known in the privacy concerning community, which is also rather common for SFOS. Blocking of trackers is rather relevant for privacy aware users of SFOS. Not only for native apps but also within AlienDalvik. Actually I appreciate this thread.
For myself, I cannot see any accumulation of buzzwords. If the question doesn’t tell you anything, why don’t you just ignore it? No-one expects you to react to every question.


The advice still stands. If the post would be about the actual technology (and how it fails) and not the service name, it stands a better chance of attention. Which i do agree it deserves.

The so-called “privacy concerning community” has quite a lot of FUD and straight-up false marketing. No need for anyone to have to sift through that to understand an issue if it can be helped.

Fair, let’s not say buzzwords primarily then, but brand names. There is no magic here, just networking.

Forget about commercial buzzwords and just use Defender already. That works, and is free.
(Note: current version has a bug in the GUI but works perfectly from the command line).

Thanks for your reply. I tried Defender. I found out I have to start the program as defaultuser.

It is staggering to note that whenever I use Defender (and disable OpenVPN), the problem reoccurs. However: now it is such that I actually think I should report a bug here. Even the default browser of SfOS is not protected by Defender when I switch to 4G. I am very shocked by this. I hope that there will now be a serious look at the problem that occurs with 4G connections.

BTW: the problem has nothing to do with ProtonVPN!!!

Minor update: when using Defender I am not protected on 4G at all. When using ProtonVPN I am protected on SfOS, not when using Android.

Thanks for your attention.