Need help unbrick XA2 after failed update to

I have successfully updated to and everything was working just fine.
Then is did the update to and my XA2 wont get past the Sony logo.

I managed to get into recovery with the image, mount encrypted home and chroot into /rootfs
I could create routes to establish an internet connection from XA2 via the host/rndis.
I could also find the necessary files in the repos to install zypper - mounted the update cache in /home to the system repo cache and tried a zypper dup

Now i have the problem that aliendalvik could not be downloaded becuse there ist no dbus available in chroot and credentials could not be read.

Failed to provide Package aliendalvik-1.0.0-1.12.1.jolla.armv7hl (aliendalvik). Do you want to retry retrieval?

[aliendalvik|plugin:ssu?repo=aliendalvik] Can't provide file './armv7hl/aliendalvik-1.0.0-1.12.1.jolla.armv7hl.rpm' from repository 'aliendalvik'
 - Store credentials not received. Not connected to D-Bus server
 - Can't provide ./armv7hl/aliendalvik-1.0.0-1.12.1.jolla.armv7hl.rpm

Does anyone have a hint how to manage that issue?

Strange thing is that zypper dup wants to downgrade a high number of packages from to

Why do you need Alien Dalvik to get it to boot?

as i wrote the problem is the update went wrong and the phone does not want to boot.

now i want to apply the update manually via chroot and the only thing that holds ‘zypper dup’ back from succeeding is the aliendalvik package because zypper cannot download it. and obviously that is because dbus is not available to get the store credentials.

i do not want to remove aliendalvik though because all andoid data would be lost.

Removing Alien Dalvik (or not installing it) doesn’t actually destroy Android data. wouldn’t install for me without AD’s installation file though Whilst it’s possible updated it, it might point to version confusion.

I can’t really help you more than that but it might trigger something for you or someone else.

Just do a re-flash. I don’t thing the time digging a solution is worth.


Reflashing would be the last resort which i am not at right now.
i love to learn by doing something and i am very much interested in fixing the system

At everybody else:
my question would be is there a way to provide the store credentials in any other way than via dbus?

1 Like

After poking around a bit with zypper in chroot mode i did a zypper refresh and zypper update it reported that the packages systemd, systemd-libs and patterns-sailfish-mw could not be updated because of dependency issues with systemd-compat-libs.
zypper made the proposal to remove systemd-compat-libs which a agreed on.
zypper update finished and i left chroot and unmounted home and proc and closed the encrypted partition. Finally i left recovery and did a reboot.
I could then get past the Sony logo and SFOS tried to do the update to which failed and said something like 'upgrade failed, try again later [reboot]. It rebooted then once again and got me into the fully working


What he doesn’t say is whether he had Android apps installed.

I tried this under 3.4 and although the Jolla Store said it was uninstalled, all my Android apps still worked. I reinstalled it and could tell from the speed that it didn’t download any ~100MB installation file.

So it might prevent Alien Dalvik from being uninstalled when Android apps are still installed. Or this might be a new behaviour since 2016.

ok thanks for your observation and reply!