Need help setting up the SDK

I’m a computer engineering student and I wanted to try my hand at SailfishOS development. I’ve donwloaded the SDK and installed in Windows 10 in accordance with the instructions in the documentation (with oracle VM and msys2), but nothing in the SDK is working as expected.
I tried loading one of the example packages but when I try to run with i486 it gets stuck at “Start Build Engine: Starting “Sailfish SDK Build Engine” virtual machine…”. If I try to start “virtual machine” from “options” nothing happends. Trying to change anything in options does nothing. Sometimes a progress bar shows up but it doesn’t indicate what it’s attempting to progress in and it never manages to finish whatever it’s doing, and I’m not able to “abort”.

I’ve noticed that in options, under kits, only i486 has a “device”, but trying to change anything does nothing as far as I can tell. Aarch64 is set as default but that kit has a yellow warning triangle next to it and trying to change default, once again, does nothing.

This is a clean Win10 install. I’ve only installed whatever the installation instructions had me install, as well as some other dev tools and software that I need for school (intellij, vscode, github desktop etc.).

Any and all suggestions are greatly appreciated. I’m clearly not an experienced developer and even getting the SDK up and running has me in over my head, but I’m still hoping that someone will be able to help me out so that I can get a solid “hello world” up and running here.

If you open the virtualbox manager does it list the build engine vm?

ask if you have no idea what i mean :wink:

Virtualbox manager has two VM’s listed:
Sailfish SDK Build Engine

I rebooted my machine now and after trying to build a project a progress bar pops up that says:
“Connecting to the “Sailfish SDK Build Engine” virtual machine”
But it never does and nothing else happends, but virtualbox manager now has the VM as “running”.

if you run the sdk maintenance tool → add features, what is listed as installed below Build Targets?

It might also help to ask in the irc channel at oftc

thanks thigg, I’ll check out the irc.
I’ve got checkmarks on:
SailfishOS-latest-aarch64 (…)
SailfishOS-latest-armv7hl (…)
SailfishOS-latest-i486 (…)

Installing VirtualBox 6.1.40 instead of 7.0 solved all my issues. Thanks to mal on the irc and to thigg for pointing me in the right direction :slight_smile: