Mobiilivarmenne fails with 3.4.0

REPRODUCIBILITY (% or how often): ??
BUILD ID = OS VERSION (Settings > About product): 3.4.0.24
HARDWARE (Jolla1, Tablet, XA2,…): XA2 Dual-SIM
UI LANGUAGE: Finnish
REGRESSION: (compared to previous public release: Yes, No, ?): Yes

DESCRIPTION:
After upgrade from 3.3, Mobiilivarmenne stopped working and cannot be reinstallled.

PRECONDITIONS:
Mobiilivarmenne is Finnish SIM-based personal authentication system. It is supposed to be OS agnostic and for me, it has worked with Salifish over several recent versions and survived upgrades with no issues.

STEPS TO REPRODUCE:

  1. Activate Mobiilivarmenne with a version prior to 3.4.0
  2. Upgrade to 3.4.0
  3. Try to authenticate with a supporting site -> timeout
  4. Try to reactivate Mobiilivarmenne using carrier interface (eg. for Telia: https://www.telia.fi/mobiilivarmenne/activation.do) -> failure

EXPECTED RESULT:
Authentication works

ACTUAL RESULT:
Authentication fails with timeout.

ADDITIONAL INFORMATION:
After trying reactivation, I get SMS with message: “Mobiilivarmenne registration failed. Error code 13.”
The related SIM icon was on phone screen with title “Telia” before and after phone upgrade. I uninstalled it between successive reactivation attempts. No effect to outcome.

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Doesn’t seem to currently work for me either (Telia/Xperia 10 Plus). I’m getting either “unexpected error, please try to reauthenticate” or just the transaction ID followed by a timeout. Tried on kanta.fi and vero.fi. I don’t think I’ve even tried on 3.4.0 before. Might be an issue on Telia’s side as well?

I was just able to authenticate via Mobiilivarmenne twice, although the first attempt was very slow (I had already canceled the login on browser when the PIN query appeared on the phone)

Never worked for me after the upgrade, I allowed for very generous timeouts. I get the error SMS when trying to reinstall. Before upgrade, absolutely no problems. Is anybody looking on this?

Thanks for reporting this, IAX. There seem to be multiple problems. It may happen that the SIM ATK window with the ID code appears under the browser window (where you triggered the authentication session). So in this case, the browser window should be swiped aside first. It may appear later, after a rather long period of waiting. Secondly, the pulley menu does not work flawlessly: if you do not hit the OK button correctly there is no other try as the OK button disappears from the menu… Weird. A third problem is that pulling the menu down may not work as if the touch screen did not react. And the 4th: the window with the code may never appear.
==> Going to file a bug or bugs.

1 Like

Great!

Just to note that I was actually on a desktop browser and using the phone just for authentication. I can’t test with sfos browser any more, as re-installing the software always fails.