MMS works on XA2 Plus but not on Xperia 10 II

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): ?


I cannot download MMS messages on my Xperia 10 II. It works with the same settings, OS version on my XA2 Plus. Both are dual sim. Wifi is off when I try and I cancel and restart the message just to be sure.




  1. Receive or send an MMS message
  2. Click to download
  3. Will either say downloading or waiting, but eventually fails.


MMS message is downloaded.


Says MMS message failed to download.



1 Like

I have the same issue on my 10 II. Sometime it will download if I enable WiFi, but it’s not consistent.

1 Like

How about wireless data – is that working okay? Have you tried changing Network mode (my 10 II is set to “prefer 4g”) in the Cellular network page and Protocol for MMS access point (“IP” in my case) to see if it makes a difference? In my case, those things mattered when I didn’t think they would.

Oh, and MMS proxy . . . are you using a URL or numeric IP address? On my 10 II, I had to use numeric IP – some kind of DNS issue going on.


Changing to the numeric IP did the trick. Thank you immensely, you have made my life just a little bit happier!

Unfortunately not a working solution for me. It might have helped somewhat with the nummeric IP for the mms proxy, but I still need to enable WiFi to be able to send and receive mms. Mobile data is working as expected and I have changed every setting IP/IPv6/Dual etc. but I still need the WiFi connection.

Ofono logger was just built for aarch64, so maybe MMS logger is coming right behind it and can be of some help diagnosing this issue.

Still have issues with downloading mms but as of now I usually will be able to start the download if I enable WiFi Hotspot. It might take a while though… But I no longer need to be connected to a separate WiFi network or fiddle with the IP settings.

I’ve problems receiving MMS, but sending works fine (after the MMS Access Point name was adjusted).
SF 4.1 on Xperia 10 ii.

The problem is not that I cannot “download MMS messages” in the way that “clicking to download” fails, as stated in OP. (I guess this means that clicking the thumbnail in a received message won’t make the full media file download.)

In my case the problem rather is that MMS messages sent to me are not at all received in the phone. (24 hours after any MMS have been sent to me, my telcom provider sends me a SMS with a message that a MMS message has been received and I’m given an URL and password to access it via web.)

I remember that some years ago I had a similar problem with my Xperia X, but cannot now remember what was done to remedy the problem.

I’ve tried to sort out the issue with the telcom provider, but so far without any success. I would believe that the problems is how my phone presents itself to the telcom provider, and the problem might therefore be either in SF or with the telcom provider (or both …).

Well, it turns out that my MMS-problem is caused by the SIM card in my Sailfish Xperia 10 ii phone being a twin SIM card, and my telcom provider only sends MMS messages to the main SIM card, not the twin SIM …

1 Like