Mint Mobile not working SailfishOS

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …):
REGRESSION: (compared to previous public release: Yes, No, ?): Yes and No, it’s always been broken from what I can tell due to the APN manager in SFOS having limitations.




  1. Install Mint Mobile SIM card
  2. Set up APN as per Android and/or iOS
  3. Observe no connectivity with MMS


MMS can send and receive pictures and group chats


MMS cannot send, nor be received.


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Are other functions besides mms working? If so, it’s not a Mint Mobile problem… mms is known to be wanky on SF

I would partly agree that this is a Yes and No on regression territory. On the one hand, Sailfish has always had some quirks with handling MMS, and it’s been consistently hit and miss. At one point, T-Mobile’s default routes worked fine, but there was eventually some statement that not using Mint’s specific wholesale APN caused severe throttling even while 4G data was available to the user, so I switched. The wholesale APN worked fine for quite a while, but as of 4.3, I’ve definitely been having issues sending and receiving MMS. I’ve tried to switch to the default MMSC from T-Mobile and no luck, I’ve tried going back to and still nothing. IPv4, IPv6, Dual, there is just no easy way of brute-forcing this issue. I feel we need to collect logs through Ofono Logger to see if there’s a specific T-Mobile or Mint Mobile issue that Jolla needs to solve.

In any case, I want to see just a more powerful and configurable APN management panel. As it is, I quickly hopped between my 10iii and XA2, tested the messaging, and without even needing to configure the 10iii’s provisioning, I was able to receive an MMS. Sending the same picture with the SIM in the XA2, which did seem to obtain APN settings from the SIM card, simply sits with “Waiting” for me now.

1 Like