MicroG in SFOS

I just bought and flashed Xperia 10 II but can’t get MicroG to work. I’ve enabled signature spoofing from Sailfish Settings, installed F-droid and MicroG Services Core etc…

But the problem is that in Android settings I would need to allow “enable system package replacement” for them, but it shows “0 of 0 apps allowed”. So I can’t allow them and thus they can’t work?

Anyone else ran into that or knows a solution to this?

This is a bit annoying as I do need some applications that require Google Services.

1 Like

Try Aliendalvik Control for do the settings. And this might help… [] Signature spoofing doesn't work on a freshly flashed xperia 10 plus - #2 by cy8aer

Unfortunately none of those were of help. The fix in that bug report that Attah found has already been fixed in Sailfish version I have.

1 Like

I get it work on my Xperia 10 II. After enabling signature spoofing in Sailfish settings, tap on microg settings → self check → System grants Signature spoofing permission.


Thank you so much… This seems to have done it.

Hello ! @ajalkane and @jumPM which were the initial steps, only F-droid and there the MicroG services .Just can’t remember what I did with XA2 years ago. Is there already AD-control for 64-bit platform, I can’t find it from openrepos? need to buikd 10-II to main driver, XA2 has some problems after update(browser and mail not runnig all else ok) , got recommendation from Zendesk to re-flash .

gives good instructions. works ok with xperia 10 II. I get all the check boxes to microG self check. Not tested with too many apps needing google yet, looks good.