MicroG in SFOS

@DrYak gave a very nice summary on the old Together on using MicroG in SFOS 3.1.

I’ve tried to use these instructions on SFOS (Pallas-Yllästunturi), and got eg. Hangouts to work, but unfortunately this seems to have made it impossible to add a Google account into the Sailfish accounts. It just says after the Consent screen, when the Google login screen should come up:

Account error
Could not create account

Anyone have suggestions on where to go next or how to debug?

(I haven’t have time to test the new beta of Sailfish OS. And probably won’t have until the official release by the Jolla devs - the joys when your day job is in Viral bioinformatics when the world is in the middle of a global pandemic).

  • You mean adding the account on the SailfishOS Native side of things?
    (In Settings -> Accounts )
  • Not on the Android side of things?
    (MicroG Settings -> Accounts/Add Google Account)
    (or: Settings -> AlienDalvik Control -> Settings -> Users & Accounts/Current user: Owner -> Add account)

Normally both are completely independent. From the point of view of Google, these are just two different phones on the same network behind the same IP address. (Which by the way is exactly how the network is set-up in the LXC).

Maybe try basic system logging with journald:
In a terminal, as root (devel-su):

journalctl --follow

and then see if some Sailfish OS daemon complains about something.

(For the record, to get Android logging, you need that:

lxc-attach -n aliendalvik /system/bin/logcat

so you view the log from within the running Aliendalvik LXC)

A possible hiccup is if you have setup the 2-factor security of your Google Account to rely on Android:
Whenever a Linux machine (such as Sailfish OS) tries to log into the Google Account, you need to confirm it in a pop-up that appears on an Android Phone (such as the AlienDalvik LXC). Maybe the security pop-up is borken under microG? (Or requires a feature that you didn’t enable, such as Cloud Messaging).
I also have an One Time Password (OTP) setup as two-factor auth (2FA) on my account. (Google calls it GAuth and it works perfectly with SailOTP on SFOS). Using such 2FA just displays an extra two-factor code input box after log-in input box when creating an account, and it has worked for me in the past.


You mean adding the account on the SailfishOS Native side of things?
(In Settings -> Accounts )

Indeed I do. Here’s what journalctl said when trying to add the Google account. I have a feeling has a thing with connectivity incorrectly being reported as not available, or something like that. Excerpt:

Oct 06 15:51:40 Sailfish QtWebProcess[27097]: [W] unknown:0 - QNAM: network not accessible, returning disabled network reply.
Oct 06 15:51:40 Sailfish estart[23178]: [D] onLoadingChanged:107 - jolla-signon-ui:inprocesswebview.qml: Load Failed! (Possibly due to invalid redirect uri)

I installed on SFOS According the self test, everything looks good, except Play Store has correct signature is not checked.
So, adding a Google account will not work, as Google will respond This account already exists on your device. I would like to run an android calendar all and android to-do list app.
therefore, this

does not work on my device.

1 Like

Hi danielfinsler,
I too am in the same situation as you, unfortunately …
We hope that the developers of microG or Jolla will be able to solve soon: I can’t even install WhatsApp! :frowning:

To ask the obvious (was not mentioned explicitly):
you did enable the ‘Disable Android App support system package verification’ in Settings - AndroidAppSupport?

1 Like

yes, this is enabled.

shouldn’t be a problem with aptoide store. On my device whatsapp backup does not work however.

Good morning,
yes of course I activated it.
I followed the guide that indicated ExTechOp.
At the moment, I’m walking around with two phones … :frowning:

Did you check https://together.jolla.com/question/222662/xa2-whatsapp-google-drive/?answer=222667#post-id-222667?
There’s a check box for allowing other apps to see accounts on device.

except Play Store has correct signature is not checked.

(Some good source about all alternatives)

For that test you need too things:

  • Some “PlaySote (Phonesky)” (com.android.vending, if I remember correctly). For that you basically have three obvious choices:

    1. microG’s own “fakestore” (it’s basically empty, does nothing and just pretends that playstore is installed, because some apps require it to be present).
    2. the official genuine Google Play Store (you can fetch it with Aurora or any other APK installing system).
    3. nanodroid has a patched version of the Google Play Store that should be playing nicely with microG, but otherwise is just the usual PlayStore.

    (To be honest, I have completely forgotten last time I need to do a purchase if I used the genuine or the patched Google Store. I just remember that one of them worked).

  • Signature spoofing must be activate for which ever of the above you picked up. (It’s in the “permissions” settings of the “Android settgins (*)”. It’s exactly the same place where you activated signature spoofing for microG)

So, adding a Google account will not work, as Google will respond This account already exists on your device .

That usually means that there is already a linked account on this android. Check in the Android settings(*). It’s in the “Users & accounts” part: your Google account should be there in the list, along with the other accounts used in Android (e.g.: Skype, Facebook Messenger, WhatsApp, etc.)

I would like to run an android calendar all and android to-do list app.

Use Aurora Store, it’s available in F-Droid and can download apps from the Play Store. That’s what I do.
Most apps should already work on your phone (given the microG self-check results), a few might complain as currently no playstore is signed correctly.

(*): I find using Aliendalvik Control the easiest to reach the settings. Just go: “Settings -> AlienDalvik Control -> Settings -> Users & Accounts/Current user: Ownert”


I can’t even install WhatsApp!

That is weird. WhatsApp doesn’t even require Google Play Services. It’s possible to install it on a bare AOSP, or on smartphone running completely different services (Amazon’s services, whatever they have in China, etc.)

Google Pay Services are only used for:

  • accessing Google Drive (for the backups)
  • using Google Cloud Messaging to automatically waking up the app and fetch new incoming messages, even if the app is not running in foreground.

microG support those as long as an account has been setup.
But WhatsApp will happily work without them.


I do not know what to tell you…
I have been trying to understand something for 3 days, and in the meantime I cannot send photos and / or videos from WhatsApp nor can I download them. Same thing goes for audio.
Yet I ran the flash procedure of 3.4.22 twice …
Where am I doing wrong? Could it be my Xperia XA2 Dual sim having problems?

Note that flashing DOES NOT overwrite the Aliendalvik image partition. That is the system.img file stored on a separate /opt/alien/ filesystem.

  • You haven’t touched your system.img, right ? (e.g.: by trying to patch Google services in there).
    Otherwise, it would be best to delete the content of /opt/alien to make sure that your mods don’t conflict with trying to install the RPM.
  • You should try reinstalling the aliendalvik-system package (zypper install --force aliendalvik-system).

Did you try to allow android apps to see the accounts? I had the same error message with Whattsapp backups, and Ralf’s answer solved the problem.

1 Like

I thank you for the answer. Yes I tried Ralf’s suggestion, but nothing has changed unfortunately.
I will try to follow DrYak’s advice, which is to install alien-dalvik again.
And in case I go around with two phones: I don’t feel like leaving Sailfish! :cry:

To me microG works correctly with Sailfish About your problem, have you checked that the fakestore has been activated from the “app permissions” menu from the AlienDalvik settings?

Open AlienDalvik Settings -> App and notifications -> App permissions -> enable system package replacement -> FakeStore.

The setting should look like this:

in my installation, the self-check is missing the Play Store (Phonesky) has correct signature check mark. All other items are checked as correct.
How to fix that?

Did you manually copy your WhatsApp folder from an backup? If yes, then you have to recursively set the permissions correctly for the whole WhatsApp folder otherwise the app won’t be able to read/write to the directory. IIRC the correct permission is something like “media_rw” (I can’t check it right now).


Great!!! Thank you!!! :smiley:
I solved: now I can backup the chats locally and download all the media and documents they send me !!!
Thanks again and have a nice day! :smiley:

As for microG and spoofing permissions, I solved it by going back to version, installing and configuring microG and then updating to everything works perfectly!

1 Like