Message App and People App will not open if message app is closed + and High battery drain

OS VERSION: OS 4.4 build
HARDWARE: Sony Xperia xa2 dual sim
UI LANGUAGE: english uk


/ I have been having the double type issues since 4 version back or when Jolla patched the issues not sure when that was. The locked messag apps after close ststartestarted 3 versions or so back


as stated above if thethe message appliapplication isis closed it cant be reopened with rebooting. If it is opened and closed the phone becomes a paper weight and has to be rebooted or it will get warm (most likely cause a fire) and the batter rapidly discharges. Message and people app stop work. It bites.


open message app the close the app and the phone goes into melt down mode as the battery discharges. Other apps stop working. It has been reported before jolla failed to address the issues. Now its worst as the people app fails to open now.


  1. open messaging application

  2. close messaging application

  3. open marshmallows and roast the over hot phone as it melts down due to rapid battery discharge

  4. to prevent this open messages and never close it


I want my phone and os to work and not catch my flat on fire. (i dont have a bad battery)


cant open applications phone gets hot until rebooted.




  1. List item

jolla fix it!

Can’t reproduce.
Sounds like something is seriously broken on your end… maybe try a reflash.

1 Like

Please specify the os version and hardware in the top of the bug report template.

Also, can you use top/htop/Crest to find out which process is causing a high load in that situation?


I did say the hsrdware and the version is the latest. Please feel free to add it to the thread if you know whst the lastest paidpaid versionversion isis asas II don’t…

you thinkthink something is wrong withwith thethe hhardware ?

The hardware was workingworking greaygreat untiluntil 4 versions ago… As reportedreported beforebefore all thisthis double typing is happening onon itsits ownown im notnot doing this. The phonephone goes on a roll and it justjust happens. This dod not happen until jollajolla had thatthat keyboard bug and my phone has been nuts every since.

im thinking its software. You mentioned a software…where can I find this software?


Can you point me to this top crest app…thanks

htop is available from jolla:

pkcon install htop-desktop

Crest is available in Jolla Store, but the latest version is on Openrepos:


Thanks for your bug report @808. You’re clearly suffering from some issues on your phone and it would be good to get to the bottom of it.

As requested by @nephros, it would be really helpful if you could please edit your original report to fill out these fields here at the top of the bug report:


Without these, it’s a real challenge for us to test the bug.

Here’s how to find this info:

  • OS VERSION: Settings app > About product > Build (e.g. “”)
  • HARDWARE: Settings app > About product > Product name (e.g. Xperia 10 - Dual SIM).
  • UI LANGUAGE: Settings app > Language > Highlighted item (e.g. English (UK)).
  • REGRESSION: Did you experience this before your last Sailfish OS upgrade? If you did then answer “No”. If you didn’t then answer “Yes”.

Do you have developer mode installed on your phone and would you be in a position to run some commands and/or collect some logs? We can provide clear instructions, but this may help get to the bottom of it and address the underlying issue on your phone.

I’d also second @nephros’s helpful suggest to use top, htop or Crest to find out which process is running hot. This is likely to be really useful in narrowing down the issue.

  1. I can not edit your posts.
  2. This is your bug report. If your goal is to get it fixed, please take the time to fill out the information required to do it. The guide how to get to that information is right there in the bug report template.
  3. What is “latest version of hardware” supposed to be? Can you say which device you are running?

Thank you so very much for the tips. I did not know about the about feature. I can turn developer mode on

Yes I am willing to run comnands or softwsoftware as long as my security and privacy are not violated

I will edit the post as well but here are screenshots of the stuff as well.

so this regression question is odd so since i havr had this for the last for releases i need to answer no correct?

seem like the answer would be yes but clearly i dont know whst regression means in realation to computer and programming

When I run the version from store i get this

Ok so I havr this crest tool.installed and closed the message application and now trying to reopen it… No go

i saw aa process called message server so i killed it… Still no go.

in the time it has taken me to.craft this message the battery has drained down an additional 2% and the nuclear core in this thing is heating up… Gonna sit aa pork pie sausage roll on top of it to heat it up for supper.

interesting something new… Not sure ifif itsits due to thisthis crest tool running but the screen shot uploads take at least 5mins notice the time and the battery drain between these pictures

Going to reboot to see if i cann see something different

1 Like

SO while all that high temp and load is happening, do this:

  • open crest
  • pull down menu
  • select “show all processes”
  • select “sort by CPU” (this should be selected by default so probably not necessary)
  • look at it for a while, identify which processes use a lot of CPU
1 Like

SoI left the phone on the charger for about 8hours after closing the jolla message application and took screen shots. The phone only charged to 45% so there is something very power hungry running not sure if crest application shows it but below are the shots…some are from a day or two before when the os was acting whacky.

the first picture is tge latest but i took it with the web browser on… I will add onefrom today with out the web browser on it will be the last picture



Nothing there looks particularly crazy in those screenshots as far as I can tell :thinking: Even 44.3% for the browser probably isn’t exceptional.

It’s possible your device isn’t moving into sleep mode when the screen is off for some reason. I’m not sure how to test that though; I’d have to look into it.

1 Like

Here are pictures without the browser running… I let the crest app run for 17 hours and as stated the phone was on the power chager for at least 8 and did not charge pass 45% also i attempted to start the people and messages applications . They will not start.
phone works fine if i dont close the messaging application or if I dont open it. If I open iand close it after use …the meltdown begins.

Apps like System Monitor have CPU sleep graphs.

Just as a final demonstration of battery drain.
in just the time it has taken to write these messages look at the battery drain… Just a few mins have elapsed

Should i get that? Is that on the storestore thingthing? ← see that double type action…phone is in full filp out mode

Thank you… Im going to reboot before this thing turns into a silica puddle.

1 Like