Media player doesn't find files

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): XA2
UI LANGUAGE: (not sure what to put here)
REGRESSION: (compared to previous public release: Yes, No, ?): Yes


Media player can’t find some of my mp3 files, all in the same folder, while the files in a parallel subfolder are found. I tried clearing the tracker cache using the utilities in the setup. I also tried removing all files under /home/nemo/.cache/tracker3/ and rebooting. This did not work,

Using the File Browser app I can see the files and play them. (I also see them with ls of course).

I copied one of the files into the parallel folder, and cleared the tracker cache. I then saw that file in the media player in the corresponding album, and could play it.

I then tried renaming the parent directory holding the two directories with mp3 files. Again, after rebuilding the tracker cache Media player can find files in one subdirectory and not the other.


For most of my music directories it works; I’m not sure how to reproduce it with another directory, but for the directory it does not work I haven’t been able to make it work.


  1. Open Media Player
  2. Select an “Album”
  3. Notice it seems empty.


I should see the files and be able to play them


I don’t see any files with Media player


(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Had/have the same issue with .flac files that are on my SD card. Some albums don’t appear at all (can play if you browse to them from the file browser) and others only show the cover and are empty when you select them.

There doesn’t seem to be an issue with the files themselves.

It seems it was a problem with my files. The album named in the mp3 meta data contained a slash. I removed that, and now it works. (There was another complication in that I had duplicates of these files, but the removal of the slash definitely helped.)