Manually configuring WLAN IP settings makes them visible the first time Update IP automatically is unchecked

REPRODUCIBILITY (% or how often): unknown
BUILD ID = OS VERSION (Settings > About product): (Verla)
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): Unknown


In Settings → WLAN → SSID → Advanced unchecking Update IP automatically doesn’t erase the boxes until the menu is revisited.


I wished to change my DNS server and configured IP outside of my DHCP range for my home network.


  1. Open Settings → WLAN
  2. Touch the network and select edit
  3. Uncheck update IP automatically and fill in the details updating IP address to something unmanaged by DHCP.
  1. See that all boxes are filled, fill in DNS servers. Related bug: IPv6 DNS servers cannot be entered
  2. Leave the menu, maybe even reboot the phone
  3. Observe not getitng connected to the network.
  4. Return to the menu and see that DNS servers are the only filled details.


The phone connects to the network without issues using configuration I specified.


The searching for WLAN symbol is visible on top right of the screen and I won’t get connected to the network as all other options than DNS servers were removed (including device IP address and DHCP server).


I don’t have logs or screenshots from all the phases.

What I expected to do was change my DNS server (IPv4, IPv6) without having to specify manual connection details (per WLAN network), as per my comment in Support DOH for Sailfish - #7 by Mikaela .

This issue also resulted me finding out that my Xperia 10 II MAC address leaks (IPv6 Privacy Extensions aren't enabled) and I am only able to use IPv4 DNS servers resulting into practically getting disconnected from the internet when there is IPv4 trouble not affecting IPv6 (has happened once or twice in Finland in my experience).