Make updating Android (System)Webview possible

REPRODUCIBILITY: 100% (always)
OSVERSION: 4.5.0.18
HARDWARE: Sony Xperia 10 III - xqbt52 - xqbt52 - 1.0.1.18 - aarch64
UI LANGUAGE: Nederlands (user: nl_NL, os: nl_NL.utf8)
REGRESSION: not specified

DESCRIPTION:

Android Webview is used in a lots of Android applications, and even in the latest Android runtime supplied with Sailfish 4.5 on X10III, is a very old one, version 83. Version 83 is from the beginning of 2020.
Some Android apps like Tutanota already require a newer version and do not work anymore on Sailfish.

So although Android 10 or 11 will be absolutely fine for most apps in the near future, Android WebView 83 isn’t. We can expect more and more apps to break as time goes by. This is even a bigger problem for devices stuck on Android 10 or older.
My banking app “Rabobank” also stopped working on Sailfish 4.4 as it “upped” requirement to version 83(it works again on Saifish 4.5, but for how long?).

As auto update for WebView isn’t possible due various reasons(no Google play store and possible others) it would be very helpful if Jolla at least makes it possible(or explores the possibility) to install a secondary Android WebView. This feature(multiple Android WebViews) is normally used for debugging purposes on real android. But this is not allowed in the Jolla Android image.
See link Installing SystemWebView · bromite/bromite Wiki · GitHub for relevant information about this subject.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Install Tutanova app

EXPECTED RESULTS:

Working app

ACTUAL RESULTS:

App not working

MODIFICATIONS:

  • Patchmanager: yes
  • OpenRepos: yes
  • Chum: yes
  • Other: none specified

ADDITIONAL INFORMATION:

Device Owner User: defaultuser
Home Encryption: enabled


the initial version of this bug report was created using Bugger 0.9.9+git1
5 Likes

Could Jolla please say something about this?
Android webview 83 from April 17, 2020 isn’t OK to use when it’s almost 2024.

As far as I know (also see link above ) it should be pretty simple for Jolla to at least allow alternative webviews to install like https://github.com/chromium/chromium/blob/main/android_webview/docs/prerelease.md

3 Likes

This would solve my problems too. The Rabobank app does not work properly anymore and while installing other webviews work fine they don’t show up in the developer settings menu.

1 Like

You can install Android System Webview. You can do this via Aurora Store.
The latest versions of Android System Webview require trichromelibrary. The current version of Aurora Store should install it automatically when you select an app requiring it, although it does not warn you, but rather shows the three flashing balls which might lead you to think that something has gone wrong. Instead, it is downloading the library (it is very big, about 100 MB) and when it’s done you will be presented with a requester asking to install it. Remember, this can take many minutes.
If installing Android System Webview does not work straight away, try installing Google Chrome first. It will download and install thrichromelibrary. As before, you will not be warned, so wait patiently looking at the flashing balls.

1 Like

Yes you can install it, I even tried this a while ago. But I was not able to activate it in the developer settings because it didn’t show up. So you can’t use it.

1 Like

Not trying to be rude, but did you even read my post?
You can install other webviews like bromite or Google canary or beta webview. However, those aren’t allowed by (jolla’s) Android configuration(those should be added to a configuration file in the Android image) to be used as a system webview, so they only take up space and won’t do anything. Other apps can only use the many years old default webview.

More info: https://github.com/chromium/chromium/blob/main/android_webview/docs/prerelease.md

1 Like

I am not telling to install another webview, I am telling to install the regular Android System Webview. Since I did it, many apps which were working badly now appear to be working fine. Webview on Android 11 is based on trichromelibrary, therefore updating trichromelibrary you should get updated functionality.

You can install trichromelibrary and exact same version of ‘a’ webview. You still won’t be able to USE that webview for other apps.
If you did, as you say, upgrade the default system webview, please verify it in android developer settings(that it is not version 83) or install FOSS browser from example F-droid a go to a browser check page like https://www.whatismybrowser.com/

1 Like

I just tried to add a line to config_webview_package.xml inside the framework_res.apk:

<webviewprovider availableByDefault="true" description="Google Android WebView" packageName="com.google.android.webview" />

And re-generate the squashfs for the system.img; unfortunately it didn’t load properly (the android support didn’t start any more). I guess I used wrong signing for the apk. I wonder if it is the default platform key from the android 11 sdk that should be used or something else?

DId anyone manage to update the webview?

1 Like

Nice question. Tried to update on Chromium Webview (from LineageOS) - because in AppSupport of Sailfish built in Chromium Webview, not Android System Webview.

But - install fails. Not installed. Tried to off built in 83.0.4103.120 and install new version of Chromium Webview - same, not installed. Intuition feeling says that may be try to delete with root rights built-in Chromium Webview 83.xx… and install after new version of 103.0.5060.71 (for example).

If success - tell us please)

I wonder if the Webview is custom and not possible to be replaced because of the chooser that pops up when you click on the link that allows you to choose native SFOS browser. And if we installed Android’s default Webview this optipn would be gone?

You have this option also when using a link in any other app, there seems to be some “android app” that redirects the link to the sfos browser.

I think I’m affected by this with Epassi app. When trying to sign in there is a friendlycaptcha.eu that does not work.