Make Aqua Fish to think it's Jolla C

Dear all,

I want to overwrite the Intex Aqua Fish so that it behaves like a Jolla C and does not have the Intex Store and no Google code I do not need.

In 2017 I followed the How To with the called title from “Coderus” in the old Forum (link at the bottom). It was hard work for me then, but I did it. I want to try again now because I reset the phone. But I do again not understand especially the beginning of the How To. How do I start? I installed Putty. Do I have to begin with 1. of the “Simple Steps”? How do I use the link? Copy the file or content somewhere?

How about copying the How To in the new forum and make some points more clear for newbies?

https://together.jolla.com/question/148893/how-to-make-aqua-fish-to-think-its-jolla-c-not-modem/

Thank you!

Marco

easy way today is to reflash with firmware from
https://talk.maemo.org/showthread.php?p=1549980

Many thanks, Coderus!

In the last months I flashed Samsung Galaxy S7 and S7 Edge sucessfully with the Android Custom ROM Resurrection Remix. Is it the same process with an Intex/Jolla phone? Do I install TWRP in the first step and so on? Or is it different here?

And the many files behind the link you sent do not make it clear to me which I need and how I use it…

I found very good How Tos for flashing Android phones with Android custom ROMs. I only skip the part where they tell me to install a big pack of Google apps:

Thanks again, have a good day!

Marco

@Dante

You don’t say whether you want to permanently delete Intex content or happy that device would revert to AquaFish on future reset. Provided device currently running ‘factory reset’ version of the Intex Aquafish (2.0.2.45 (Aurajoki), use of Coderus script is probably easiest as can be carried out either via terminal upon device of SSH into it via Putty.
Developer Mode = On
Open terminal upon aquaFish or login to remote shell

devel-su

bash <(curl -s https://raw.githubusercontent.com/CODeRUS/aqua-fish-to-jolla-c/master/script.sh)

Follow prompts elicited during installation.

Thanks, Aspergerguy,

Coderus told in his How To that a factory reset will always bring back the original Intex stuff; I would be happy, if it would go forever, so my work now would be already done. So, Terminal is another App either on the phone or the computer, I guess. I am sure, I did this before, but I have to translate and find this again, because it is not something I do regularely.

Regards, Marco, befriended with asperger guys in real life

@Dante

You need to go to Settings > System > Developer tools > Developer mode to install Terminal on AquaFish

Thanks, you showed it great.
Actually it takes long when I want to start developer mode; “there is a problem with the shop”. Same when I try to install a game from the shop. Should I establish a new user, not the one from my Jolla 1 ? I try.

Game app is now there, took long.

Tried this:
https://together.jolla.com/question/131055/developer-mode-fails-to-activate-with-problem-on-installing-jolla-developer-mode/
But the problem still is the same. Can not start developer mode, while I can use the Jolla store.
Point 7 from the link returned: “Failed to obtain authentication.”
I fear, it is time to give up.
Thanks again.

Whilst I had Intex AquaFish in the past, was using Jolla C to provide screenshots in post. Might have suggested trying “Recovery mode” using this resource:
https://jolla.zendesk.com/hc/en-us/articles/115000663928-Jolla-C-and-Aqua-Fish-How-to-use-Recovery-Mode

Hi Dante and everyone,

This August 2021, I had to need to update my Intex Aqua Fish to release 3 or 4. Now, I just updated to 4.0.1.48 (Koli), using CODeRUS script, from the old forum thread “[[How-to] Make Aqua Fish to think it’s Jolla C [not modem]” as you tried. But there are any tips you need to know.

I recommend old forum thread Did anyone manage to update an Intex Aqua Fish or Jolla C to Release 3.0.3.8? [closed] - together.jolla.com

  1. Make a factory reset of Intex Aqua Fish
  2. Don’t update Intex Aqua Fish !
  3. Enable developer mode in the system settings.

Here, there is a problem, the version 2.0.2.45 (Aurajoki) seem not to exist, showing a “there is a problem with the shop” message. To resolve, I read the old forum thread [[Aqua Fish / Jolla C] Developer Mode missing after 2.1.1 update [closed] - together . jolla . com]
The solution is to install one versión (I used the first one and it work) of FirgerTerm manually from FingerTerm (Terminal app) | OpenRepos.net — Community Repository System
Don’t forget to enable the installing untrusted software (Settings) to enable third party packages. Tap the downloaded package run the instal process.
Now that you have the terminal, open it, You need to change the system version to the nearest from 2.0.2.45; I found 2.0.2.47, and I execute

$ ssu re 2.0.2.47

When you try to enabled developer mode, It must work.

  1. Enable remote controll in developer mode settings.
  2. If you want remote access, connect to the Intex Aqua Fish in any terminal app ssh nemo@<ip-adress-of-your-phone>, if not, simply, use the opened terminal
  3. Execute the [suggested CODeRUS script] in this forum.
$ devel-su

The devel-su command ask for password, the same as remote control (step 4).

$ bash <(curl -s https://raw.githubusercontent.com/CODeRUS/aqua-fish-to-jolla-c/master/script.sh)

The script ask for some actions, that you have to answer with option 1, to eliminate Intex packages.

  1. Reboot your Intex Aqua Fish.
$ reboot
  1. Update your Intex Aqua Fish with the regular way in your settings.

The OTA updates automatically offered by the OS (initially 2.0.2.45 Aurajoki) were the stop versions:
2.0.5.6 Haapajoki (430 MB)
2.2.0.29 Mouhijoki (460 MB)
3.0.0.8 Lemmenjoki (410 MB)
3.2.0.12 Torronsuo (420 MB)
3.4.0.24 Pallas-Yllästunturi (420 MB)
4.0.1.48 Torronsuo (420 MB)

1 Like