MAIL CONFIG INSTABLE / Its impossible to touch the config without being afraid crashing the state

I had a mail config in use where everything worked (deliver mail via SMTP 465 (Type: SSL)) and receiving via IMAP 993 (Type: SSL). Now, I was requested by my employer to change the password. Bumm! Nothing works now. Really nothing!

  • The current config is not accepted by the application anymore (no receiving mail)
  • Deleting the account and recreating it does not works (timeout while checking the new config)
    • done via system preferences and directly via mail application

How can this happen? The exact same config (connection to the mail server) was working! Incredible (I am talking about “mail”, a basic service)!

Despite having deleted the account for recreation following was delete additionally manually:

./.local/share/jolla-email/ ./.local/share/com.jolla/email ./.config/com.jolla/email ./.cache/com.jolla/email

After this the account could be added again.

PS: Just to clarify - i wanted just to change the password in an existing account but was forced to heuristically approach the problem until landing in the CLI. A good UX is for sure different.

HW: Xperia 10 and Xperia 10m2

1 Like

May I ask you to edit your topic and use the awesome template ?
It helps us a lot. In fact, it saves us a lot of time.

In the future, you can even install an application to fill in your bug report.

That’s a bit strange. None of those would be used for storing Account info. That’s all in : .local/share/system/privileged/Accounts/ and Secrets. I’ve experienced account updates failing on major (3.4 → 4.x) upgrades so I get your pain.

Could you tell us which version of SFOS at least. I’m assuming some 4.x?

1 Like

@poetaster, thanks. The whole thing is strange. jolla-email is always a recurring topic, here (forum/tjc) and also experienced by my self in the last couple of years (@pherjung for formated/formal bug reports search here and in TJC). This topic here is a general hand raising / discussion about; why the jolla-email app passes QA in this state?
My issue today happened on two devices (Xperia 10 I/II) with SFOS and jolla-email-1.1.29-1.8.1.
The mentioned solution for both devices is maybe a coincidence in combination with reboots of the devices. I do not known the definition of done of the QA process but it should be possible to replace the account password without falling unasked in a rabbit hole. IMHO, @ jolla may I suggest following additional test scenarios?

  • change password of current account (without reboot or cli interaction)
    • passed when app is usable (send/receive mail)
  • delete account and add a new/same account (without reboot or cli interaction)
    • passed when app is usable (send/receive mail)

Is it possible that one or more file is missing or old? Due to failed upgrade for example.

Related, duplicates:

Yeah, there is definitely a persistent issue. Well, two. One issue occurs when restoring from backups which can fail and leave the device in a dirty state. There is a workflow where, if you don’t/can’t login to your jolla account when restoring, that’ll fail. That’ll leave you with half configured accounts. Numerous scenarios.

I just looked in the github repos and I don’t think we have direct access to Accounts or the Email client. Someone correct me?

I may have been bitten by that as my native mail client crashes on mail fetch.
I’ll try to take time soon to fix or at least investigate.