Lost Wifi settings


I have manual settings for my home Wifi connection set. Now and then the entered settings gets reset. The wifi settings file contains all my entered data, but for some reason they return to not set in some cases. Maybe when the networking service restarts?

Any ideas why this happens and is there a workaround?

(saw some posts about a similar issue for VPN settings, but that one is fixed.)


Did you try to reset the network with Settings → ‘Hilfsprogramme’ (Sailfish Utilities)?

Same problem for me on a XA2.
Just updated from 3.4 all the way to and this is the most annoying issue so far.

Among others I have 2 stored wifis with static IPs (of course they are the ones I use most). I did reenter the IP details 3 times already but somehow they seem to get lost. Network restart from sailfish utilities does not help.

If you feel confident in working at the command line, try this (enable the developer mode first if not done previously):

version --dup

I have tried your suggestion now. I will post in this thread when I know if it solved it or not during the upcoming days.

Thanks! :slight_smile:

I did try and it says “no updates found”.

Tonight the settings suddenly got lost again. So the version --dup made no difference.

It worked for 2 or 3 days, but today the static IP settings of one of the networks were empty again and then of course no connection is possible.
If it helps, the entries that disappear are: IP-Addr, Subnetmask, Gateway
the DNS entries always stay

Where are those values stored?

1 Like

…and another 3 days later the settings are lost again. Looks a bit like there is a timer involved???

I can confirm this on 4.2 / Xperia10 mark I.

Static IP settings are lost.

Maybe it’s when you have a 2.4 and a 5GHz network which use the same SSID?

I am not using same SSID, so not the case for me at least.

Same happens to me too, on two access points which I have static IP, only the DNS setting remains. Rarely it happens even 1 - 2 times / day on both access points, usually every 3 - 10 days. Some times it is only one access point, and 2 - 3 times happened that the same time both access points lost their settings

See this bug report for further information: Loss of static ip configuration in wifi setting