Lost connectivity

I bought a Xperia 10 III + Sailfish license approx 3 months ago. After install, everything worked great and I was very pleased by the Sailfish world. But since a week or so, i can’t get the 4G connectivity to work anymore. Same provider, no new settings or apps. I’ve tried all possible settings combinations (2G, 3G, 4G, IPV4, IPV6, mixed, airplane on/off, etc etc etc) with no success. What the hell ??? I’ve read many posts here and see that some providers are the problem. In my case (Mobile Vikings, Belgium - subsidiary of Proximus), it worked totally fine, then not at all. Any idea?? I just remember upgrading the phone OS OTA lately, but have no idea from which OS version to which - I’m now on [].

1 Like

Is your second sim slot activated?

Slot 2 contrains a SD card.

I mean in Settings → Sim Cards

It was not. I did ateivate it, failure again…

Does it work with another SIM? Does your SIM work in another phone?

What worked for me: deactivate sim 1, reactivate it, switch from preferred 4G to 3G and back to 4G.

Unfortunately not working here. When reactivating SIM 1 from the “Mobile network” menu, i see briefly “Prefer 5G” (greyed) next to Network mode, turning into “Prefer 4G/3G/2G only” menu (not greyed). None of them working. Pfff. Voodoo anyone?

Are you sure it is 5G? 5G support hasn’t been released yet. Did you install anything before the network connection malfunctioned?

1/ Deactivate SIM 1 in SIM cards menu. 2/ Go to Mobile Network menu. 3/ Touch “Activate” (SIM 1). 4/ You’ll see a greyed “5G” for 1 or 2 seconds next to “Network mode”. (Nothing to do with my problem though, I suppose - I was just surprised to see this, I hadn’t noticed it before). And no I didn’t install or tweaked anything. I’ll try to get in touch with my carrier to know if anything changed on their side.

I said from 4G to 3G. SfOs doesn’t support 5G yet.

As expected, my carrier confirms that nothing changed on their side. What else could explain the sudden loss of 4G connectivity? I’m back to my other phone - Android - and feel quite frustrated…

Which carrier?
And which settings in Settings-> Mobile network → Data access point

Mobile Vikings (BE) - Now part of Proximus
Settings: APN internet.proximus.be protocol IP authentification None

When SIM2 deactivated, Mobile data info is greyed. When SIM2 activated, Mobile date noy greyed, but i get the "limited connectivity’ message - or I get the “active” message but not working.

Have you tried DUAL or IPv6?

I’ve tried all options/combinations, yes.

New tests with 2 SIMS - same carrier for both, SIM2 working totally fine in my Android Xperia phone. None of the 4G worked in the Sailfish Xperia. Since my carrier went 5G lately, I suspect that the problem is related to some new setting/config on their side. How do I get them to look over this? That’s the challenge…

I tested the SIM card in an android phone and data works.

My carrier won’t help since “the problem is related to your phone”.
Here are the settings they require:

Nom d’apn : Mobile Internet
Apn : web.be
nom d’utilisateur : web
mot de passe : web
MCC : 206
MNC : 30
Type d’Authentification : PAP
Type d’APN : default,supl
Protocole d’APN: IPV4
Protocole d’itinérance APN: IPV4

My Android phone was stolen last weekend and i got a replacement SIM for that number. Two SIMS inserted now in my Sailsish Xperia. None of them working: “Limited connectivity”.

I also thought 5G support hasn’t been released yet.
But, this morning my XperiaX lost its mobile network connection.
The solution via airplane mode, utilities and restart network did not work here. In such stubborn cases then still helped
systemctl restart ofono or ofono.service, but not here either.
A new connection was simply not established.
After that actions I only had a hatched square in the infobar at the top right and somewhere the message no SIM card. In the settings under mobile network, I then also saw the text “Prefer 5G” under network mode (see screenshot).
Whereby I can see and set a maximum of “Prefer 4G” there if the network connection is working.
I could well imagine that a connection can no longer be established here, because an unsupported network mode is favored with “5G”.
After all the unsuccessful attempts, only a reboot helped.

I had the chance to borrow a SIM card of another carrier (Base) yesterday and data worked again instantly. I didn´t have to set the APN settings myself, they were detected and imported automatically: The weird thing in my case: data connection with my usual carrier worked for a few weeks then not anymore. I would have loved to know why, but as Mobile Vikings do not wish to investigate… i´ll just switch.