Log into free wifi on S-Bahn Stuttgart not possible through login page

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0
HARDWARE (XA2, Xperia 10…): XA2
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?):

DESCRIPTION:

I want to login into the wifi on S-Bahn Stuttgart. The button on the login page does not work, when entering through automatic login.

PRECONDITIONS:

Automatic login when connecting.

STEPS TO REPRODUCE:

  1. Activate wifi
  2. Connect to wifi
  3. Automatic landing page will be displayed

EXPECTED RESULT:

Button for login into wifi should open up the connection

ACTUAL RESULT:

Button for login does not work

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

5 Likes

Yeah, would be one more to add to this (now old and rotten) list, since Jolla has postponed(denied?) importing old reports into this forum:
https://together.jolla.com/question/7367/wiki-unsupported-problematic-websites-in-sailfish-browser/?sort=votes&page=1

You should add at least SF version (maybe also device).
And this is hard to cross-check as not near to Stuggi :wink:

2 Likes

Edited, thanks for the reminder.
The Colibri system is hopefully not only implemented in Stuttgart. :wink: I have had such a thing in a city hall around Stuttgart, too. Now, I felt like using the time and reporting it. :slight_smile:

I have exactly the same problem in Austrian long distance trains operated by ÖBB. My first trouble is that the UI is simply confusing. This pop up on the bottom of the screen … What is it for? I thought I should click on any of the 2 lines, but they are not acive links/buttons. The only purpuse of this thing is to hide a part of the screen. Useful.

Then, I have a page similar to the one shown in the original post - different, ÖBB-branded layout of course. There’s a red button I’m supposed to click on in order to log in… And it does nothing.

I don’t know if ÖBB uses the same technical solution or a different one. I can just tell the effect is the same: No Wifi on the train. And we’re talking about rides of 8 hours or even longer.

Hi there!

My workaround is to close this window and check, if I am still connected to this wifi. Then I open the SFOS browser and try to open www.google.com. This usually redirects me to the landing page of the wifi again, but with working buttons.

I hope that this helps!

1 Like

Actually, instead of opening any page that provides its content through httpS, I use http:///neverssl.com. Using an http-only page prevents me from warnings that the landing page is not SSL encrypted or that the certificate was wrong.

1 Like

Indeed, http://neverssl.com is even my default page.
A lot of those ‘landing page’ even do not show up atball when you try https…

I have noticed similar issue when connecting to NetCologne Free Hotspots, the landing page loads but cannot tick a checkbox from the page. As mentioned before, either directly accessing the login page or using neverssl.com can be used as a workaround. My phone is XA2 (4.0.1.48).

Now, this problem appears on the FritzBox guest account, too.

Same problem with wifi.bahn.de - it does open the login screen, which it didn’t before 4.0.1, but now I cannot activate the login button.
Before 4.0.1. I did not even get to the login screen in my jolla browser, but I had a workaround: typing in the address wifi.bahn.de in my duckduckgo browser made the login screen open there and I was able to log in and use wifi. This doesn’t work any longer. Quite a drain on my mobile data.
I used all the suggestions given here, but they didn’t work. I would appreciate any more ideas to work around this issue until it has been fixed.

1 Like

Have you tried Google or NeverSSL?

1 Like

Thanks for asking, yes I have, but I might not have done it correctly. So here’s what I did: Turned on wifi, ignored banner “sign in to network”, opened sailfish browser, typed in “neverssl.com” - nothing happened. Same with google. Same procedure with duckduckgo browser… nothing happened.
Variation: Turned on wifi, clicked on banner, login screen appears - but in this window of browser I cannot change address, so open browser, type in neverssl… to no avail.
Perhaps I should have done something differently?

Perhaps you need to clear the cache? When I get a connection to Neverssl, the browser saves a complete web address like this here: NeverSSL - helping you get online
I have had that kind of trouble often on trains in Germany and deleting the cache has helped.
Deleting the cache through Terminal:

rm -r ~/.mozilla/mozembed/cache2/

More Info is found here:
https://together.jolla.com/question/215408/how-to-establish-wifi-connection-in-trains-captive-portal/

Same here with a lot of hotsplots networks. Then I openend 1.1.1.1 in the SFOS browser which redirects me to the login page, where I could tick the checkbox and activate the login button.

Thank you, I tried that and then I found out how neverssl works on my browser (I made it my startpage and I expected it to open when I open the SFOS browser - and it took me a while to realize that I don’t get anywhere by just opening the browser, I have to navigate there myself.) So this problem is solved. Thank you very much!

1 Like